Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

another electrical??

Discussion in 'The Garage' started by boggerless, Mar 19, 2005.

  1. boggerless

    boggerless 1 ton status Premium Member

    Joined:
    May 26, 2003
    Posts:
    22,728
    Likes Received:
    96
    Location:
    dearborn heights, Michigan
    all the gauges worked except the oil pressure, so i pulled out the cluster only to find out the oil gauge is electric. i want the line running to it . anyway now that the cluster is back in the only gauge that works is the volt meter, and the gas gauge somewhat. if i put on the headlights the oil presure gauge drops?? but nothing else changes. WTF???? thanks daryl
     
  2. darkshadow

    darkshadow 1 ton status

    Joined:
    Dec 6, 2003
    Posts:
    12,250
    Likes Received:
    0
    Location:
    C-eh-N-eh-D-eh
    might be a ground problem, there is a gronding bloc on the left hand side behind the dash on the wall make sure is is conected to it othere than that.... ill shut up:crazy:
     
  3. boggerless

    boggerless 1 ton status Premium Member

    Joined:
    May 26, 2003
    Posts:
    22,728
    Likes Received:
    96
    Location:
    dearborn heights, Michigan
    thanks,i'll check it. i hate this crap i'm about to buy seperate gauges and mount them on the dash.:laugh:
     

Share This Page