Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

any ideas?

Discussion in 'The Garage' started by pw85k5, Apr 9, 2007.

  1. pw85k5

    pw85k5 Newbie

    Joined:
    Apr 9, 2007
    Posts:
    1
    Likes Received:
    0
    Location:
    Mt. Airy,NC
    hey guys, got a 85 jimmy 305/700r4/208, its all stock but hopefully not for long. comin' home the other night and the trans started acting a little funny. started off shifting a little late, then no OD,then no 3rd, and so on. after a few stop lights i was stuck in first. tried stoppin and shiftin manually but that didnt work:mad:. parked it, kinda late, caught a ride, went back next morn. drove it home, done fine. havent drove it since then kinda scared to. oh it was full of fluid and the fluid looked pretty new. i havent had the jimmy long so i dont know much about it. any help would be great. THANKS
     
  2. Can Can

    Can Can Pusher Man Staff Member Super Moderator

    Joined:
    Feb 17, 2000
    Posts:
    15,552
    Likes Received:
    136
    Location:
    Cochrane, Alberta, Canada
    Do you have any fluid leaking from the tranny?
     
  3. 76zimmer

    76zimmer Flyin Rat Premium Member GMOTM Winner

    Joined:
    Nov 14, 2005
    Posts:
    23,034
    Likes Received:
    1,349
    Location:
    Kzoo, Mi
    try searching 700r4 or 4l60e....lots of threads with that stuff in them.
     

Share This Page