Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Any mechanics around or near pittsburgh willing to help me!!!!!!!!

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by chvyblzr1977, May 3, 2003.

  1. chvyblzr1977

    chvyblzr1977 Registered Member

    Joined:
    Jul 18, 2001
    Posts:
    83
    Likes Received:
    0
    Location:
    Pissburgh,pa
    My blazer will not start i have no clue why there is gas getting to the carb i try starting it the carb poofs out smoke and the exhaust is smokeing as its turned off.The carb was rebuilt the distributor is brand new i need help please if anyone can help I would greatly appreicate it.
     
  2. jakeslim

    jakeslim 1/2 ton status

    Joined:
    Sep 18, 2002
    Posts:
    2,686
    Likes Received:
    0
    Location:
    Napa, CA
    was it working after you rebuilt the carb and put in new distributor? if not, you probably have the timing off.
     
  3. sunshineoffroad

    sunshineoffroad Registered Member

    Joined:
    Feb 15, 2002
    Posts:
    11
    Likes Received:
    0
    Location:
    Escanaba Mi.
    Either the timing is off, or you have your firing order off. Double check to ensure your plug wires are on the right plugs in the right order. 1-8-4-3-6-5-7-2 Have fun!
     
  4. the professor

    the professor 1/2 ton status

    Joined:
    Feb 6, 2003
    Posts:
    130
    Likes Received:
    0
    You didn't say it this problem started AFTER you rebuilt the carb/dist, or if thats why you did the work...
    ==
    On the asumption that this was the original problem, it sound like you wore out the timing chain, or the plastic gear dissintigerated and the cam timing is off
    --
    GM uses plastic coated gear teeth on an aluminum sprocket on the cam shaft...
    --
    after high milage and age, the timing chain steatches, and starts beaking the plastic teeth off...
    --
    The usual time to have this happen is when starting, usualy it will not happen when running, uless the gerar completely disintegrates.....
    ==
    The cam jumps pme pr two teeth or more, and you get the problem you have...
    --
    it takes a little experience, but you can check it by taking the drivers valve cover off, turning the crank to TDC #6 (oposite #1 in the firing order), and checking the overlap on #1..it should be split...both valves open the same amount...
    --
    /forums/images/graemlins/cool.gif /forums/images/graemlins/truck.gif
     
  5. alesko

    alesko Registered Member

    Joined:
    Apr 27, 2003
    Posts:
    47
    Likes Received:
    0
    Location:
    sw pennsylvania
    Yeah were are you located. I live a couple miles north of connelsville.
     
  6. chvyblzr1977

    chvyblzr1977 Registered Member

    Joined:
    Jul 18, 2001
    Posts:
    83
    Likes Received:
    0
    Location:
    Pissburgh,pa
    Im in munhall its right by homestead.I believe you are like a hour away maybe not sure though i need help bad with my blazer i would greatly appreciate if you could come help me out some time.I know its need the distributor put back in and it needs to be top dead center and timed i have really no clue on how to do this and i dont want to mess it up.THanks
     

Share This Page