Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Anybody started out with MORE rust than this???

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by FreedomIsntFree, Sep 5, 2005.

  1. FreedomIsntFree

    FreedomIsntFree 1/2 ton status

    Joined:
    Aug 23, 2005
    Posts:
    124
    Likes Received:
    0
    Location:
    DFW, TX
    Just showing off my new to me 75 K5. I have already installed a 4" lift and am now tackling all the rust. For now I'm just going to primer it black.

    Who else has MAJOR rust issues???

    [​IMG]
     
  2. mikey_d05

    mikey_d05 1 ton status GMOTM Winner

    Joined:
    Nov 23, 2004
    Posts:
    10,453
    Likes Received:
    0
    Location:
    Minnesota
    More rust? I dunno, mine is all hidden by bondo :haha:
     
  3. ronnny

    ronnny 1/2 ton status

    Joined:
    Nov 22, 2004
    Posts:
    838
    Likes Received:
    0
    Location:
    Newnan GA
    i wish my k10 only had that much rust. And it spent it's life in the southeast.
     
  4. FreedomIsntFree

    FreedomIsntFree 1/2 ton status

    Joined:
    Aug 23, 2005
    Posts:
    124
    Likes Received:
    0
    Location:
    DFW, TX
    Any pictures?
     
  5. muddybuddy

    muddybuddy 3/4 ton status

    Joined:
    Jan 29, 2004
    Posts:
    8,933
    Likes Received:
    1
    Location:
    Fairfax Station VA
    mine was cut out a filled with coffee can, bondo, and screws hehe
     
  6. dodgedude99

    dodgedude99 1/2 ton status

    Joined:
    Jul 12, 2003
    Posts:
    784
    Likes Received:
    0
    Location:
    burbia of illinois
    my 88 wasnt all that bad.
    now my step sons POS 90 from Michigan, you could get tetanus just looking at it.

    i started the drivers floor yesterday.

    it first started by pulling the seats outs, then the carpet, then 1/4" thick 18x24 sheets of stainless steel that the previous idiot... i mean owner bolted to what was left.

    i had to replace/fabricate the cab floor support that goes from the firewall to the bed.

    both cab mounts, the rear cab mounts are actually atached to anything.

    the front is just being supported by a sliver.

    a total nightmare.
     

Share This Page