Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Anyone got a 400 & using TBI?

Discussion in 'The Garage' started by jimmy88, Apr 28, 2002.

  1. jimmy88

    jimmy88 1/2 ton status

    Joined:
    Feb 17, 2002
    Posts:
    351
    Likes Received:
    0
    Location:
    Detroit, MI area
    I want to put my 400 in my 88 w/TBI. Thought I could use a stock type cam and just bump the fuel pressure on the holley tbi unit. After reading some of the 383 posts it doesn't look like it will be that easy. If you got a 400 and tbi whats working for you?
     
  2. Sandman

    Sandman 3/4 ton status Author

    Joined:
    Apr 15, 2002
    Posts:
    5,653
    Likes Received:
    0
    Location:
    Pocatello, ID
    I run a 400 with the Holley 2DI and it works real good. I think the specs on it say that it can only support up to 275 horses I believe. My engine puts out closer to 350 horses. I end up running it lean on the dials. As for CFM I believe the Holley is exactly the same as the stock GM unit at 670 CFM. I always wondered if I was choking some of the power off and just didnt realize it untill I went through a season of Mud-Racing and placed in the top four in every race. So its good enough and it does run better than the Edelbrock Performer carb that I took off. I say put it on.
     
  3. azblazor

    azblazor 1/2 ton status Premium Member

    Joined:
    May 5, 2001
    Posts:
    1,953
    Likes Received:
    0
    Location:
    Arizona, Phoenix area
    My son is running a stock 77 400ci (rebuilt to stock) with a stock 89 350 TBI system. We put it together a couple of months ago. Runs very good. The exception is the Holly in-line fuel pump - it's failed and the place we bought it has said Holly has to tear it apart before they will warranty it - $125 poorly spent. I won't buy another Holly. We wait for the second week with the truck parked.
     
  4. mudhog

    mudhog THEGAME Staff Member Super Moderator

    Joined:
    Nov 6, 2000
    Posts:
    17,899
    Likes Received:
    2
    Location:
    portland oregon
    send Frank (blazzinor) a pm he is running a 400 with tpi /forums/images/icons/smile.gif
     
  5. jimmy88

    jimmy88 1/2 ton status

    Joined:
    Feb 17, 2002
    Posts:
    351
    Likes Received:
    0
    Location:
    Detroit, MI area
    Thanks guys. I'll give it a shot, just don't want it to snowball into custom chip, map sensor, etc, etc, etc. BTW what cams are you using? The stock 350 one?
     

Share This Page