Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Anyone had broken off or stripped bolts on 1st gen DW top???

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Tommy, Sep 22, 2000.

  1. Tommy

    Tommy 1/2 ton status

    Joined:
    Feb 21, 2000
    Posts:
    260
    Likes Received:
    0
    Location:
    Alabama
    Just putting my top back on for winter, and about half of the bolt holes are either stripped, or have the bolt broke off in it. I have one front visor bolt hole with no nut to catch. How have you fixed. I thought of grinding a slit above rail, and sliding a tapped 4" long peice of 1/4" steel in it, then glass it back up. Do you think this would work?? Any ideas or fixes appreciated. Thanks, Tommy.

    Drive it Like You Hate It!
     
  2. K5Junkie

    K5Junkie 1/2 ton status

    Joined:
    Mar 29, 2000
    Posts:
    499
    Likes Received:
    0
    Location:
    Gulfport, MS
    I don't have a 1st gen blazer, but when putting my top back on my 90, I broke lose one of the bolts that are on the cab. It fell inside the rocker panel and i can't get to it. Sounds like the same thing happened to yours. i still haven't figured out how to fix it either.[​IMG] It sounds like maybe what you said maybe the only way of going about to fix it. Maybe someone else can shed some light on the subject.[​IMG]

    http://k5junkie.coloradok5.com/
     

Share This Page