Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Are my new ball joints toast?

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Steve_87K5, Dec 11, 2003.

  1. Steve_87K5

    Steve_87K5 1/2 ton status

    Joined:
    May 26, 2000
    Posts:
    521
    Likes Received:
    0
    Location:
    central NC
    Put in new Moog ball joints (10 bolt front end). Torqued and greased everything to spec. Now front end is loose again after very few miles. Should I just retorque everything? Have not driven truck much at all since it loosened up. I did regrease after a few miles. thanks Steve
     
  2. bckinblk

    bckinblk 1/2 ton status

    Joined:
    Jun 12, 2002
    Posts:
    305
    Likes Received:
    0
    Location:
    bristol connecticut
    When you put in the new joints did you put new sleeves back in also?? They are a biatch to get out and reqiure a special tool .If you used the old ones then that could definetly be the problem..... /forums/images/graemlins/frown.gif
     
  3. alec78

    alec78 1/2 ton status

    Joined:
    Aug 5, 2002
    Posts:
    358
    Likes Received:
    0
    Location:
    Washington
    Raise the offending wheel off the ground and make sure your movement is up and down, and not side to side or (worse yet) both. If it is side to side check the tie rod end. If both then the hub bearings may be loose.
     
  4. Steve_87K5

    Steve_87K5 1/2 ton status

    Joined:
    May 26, 2000
    Posts:
    521
    Likes Received:
    0
    Location:
    central NC
    Yes, new sleeves torqued to 70 ft lb (IIRC) Old ones came out with the special tool OK. Threads in knuckle OK. I'll recheck the wheel bearings and tie rod ends again too. thanks.
     

Share This Page