Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

audio help

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by bigoltrux77, Jun 21, 2002.

  1. bigoltrux77

    bigoltrux77 1/2 ton status

    Joined:
    Jun 12, 2002
    Posts:
    318
    Likes Received:
    0
    Location:
    Fort Polk, LA
    Im installing a JVC Kameleon head unit in my 77 Blazer. Can anyone tell me which fuse i should run the hot wire too and which to run the accessory wire to? I want to know the best one. Also where is a good place to mount a pair of Tweeters?
     
  2. 84_Chevy_K10

    84_Chevy_K10 Banned

    Joined:
    May 30, 2001
    Posts:
    17,669
    Likes Received:
    0
    Location:
    IL, USA
    The wires are already in your dash for the stereo. Go to a keyed circuit for the acc. and straight to the battery (but fused) for the hot.

    Tweeters on the A piller.
     
  3. bigoltrux77

    bigoltrux77 1/2 ton status

    Joined:
    Jun 12, 2002
    Posts:
    318
    Likes Received:
    0
    Location:
    Fort Polk, LA
    i have the cd player in.. but now when i hit small bumps, the cd skips. Is there any way i can mount the unit so it wont skip so easily?
     
  4. Blue85

    Blue85 Troll Premium Member

    Joined:
    Jul 26, 2000
    Posts:
    9,073
    Likes Received:
    486
    Location:
    Grand Rapids area
    It's important for the head unit to be attached tightly. If it can move in the dash at all, you will have problems. If that doesn't work, you might want to return it.
     
  5. bigoltrux77

    bigoltrux77 1/2 ton status

    Joined:
    Jun 12, 2002
    Posts:
    318
    Likes Received:
    0
    Location:
    Fort Polk, LA
    whenever i turn the key.. the stupid headunit starts to smoke and glow inside. What the hell is wrong!? I have all the wires going where they should! Please help
     

Share This Page