Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Backfiring

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by 76JIMMYWPG, May 12, 2002.

  1. 76JIMMYWPG

    76JIMMYWPG Registered Member

    Joined:
    Apr 28, 2002
    Posts:
    19
    Likes Received:
    0
    Location:
    Winnipeg, Manitoba, Canada
    My 76 jimmy is backfiring something fierce latley, only when i get on the gas pretty good though.The truck seems to almost stall, then when it comes back, BANG! i wake up the neighbourhood! It has a 400sb and a factory q-jet, i have noticed that my vacuum advance doesnt seem to move at all, so i'm going to try to replace that today, anyone have any ideas??
     
  2. RaisedK5

    RaisedK5 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    932
    Likes Received:
    0
    Location:
    Long Beach, CA
    That vac advance is a good place to start, plus check the mechanical advance to make sure it operates as it should, check your initial timing, and perhapse check out the carb and make sure everything, is working there, i had a similar problem and after i rebuilt the carb and swapped in a new distributor it ran a billion times better and stopped backfiring.
     
  3. 76JIMMYWPG

    76JIMMYWPG Registered Member

    Joined:
    Apr 28, 2002
    Posts:
    19
    Likes Received:
    0
    Location:
    Winnipeg, Manitoba, Canada
    Thanks for the tip, I just removed the vac advance, and it is shot, wont move at all, so I will go buy one tomorrow, and go from there!
     

Share This Page