Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Bad MPG, can anyone help me?

Discussion in 'The Garage' started by DesertDueler, Jun 20, 2003.

  1. DesertDueler

    DesertDueler 1/2 ton status

    Joined:
    May 23, 2001
    Posts:
    3,106
    Likes Received:
    0
    Location:
    Phoenix, AZ
    Okay some specs on my truck 350 (75,000 miles on motor), 700r4(rebuilt 2 yrs ago), 3.73 gears, 2.5" lift and 33" MTRs. I towed my boat to the lake today and gor 4.5 MPG., yes 4.5 MPG /forums/images/graemlins/angryfire.gif My boat and trailer are way under 3000 lbs. I didnt have the A/C on, and was only going 55-65 MPH. Only a couple of slight hills. I am mad I used 27 gallons of gas to go 120 miles. Help.

    Dan POS /forums/images/graemlins/k5.gif
     
  2. 89K1500Chevy

    89K1500Chevy 1/2 ton status

    Joined:
    Nov 9, 2002
    Posts:
    645
    Likes Received:
    0
    Location:
    Georgia, Fayetteville
    Badass your almost to where i want to be 2 Gallons to the mile.... Yeah i think my trucks KNOCK sensor has gone out cuz now my truck is idling at a vary lopey 500 rpms with lots of smoke!! but the cat converter is bad just not completely clogged Im getting bad mpgs also now so tomarrow i think ill go get a new sensor from work if it doesnt work ill be pulling off my TBI and TBI intake for the 4 bbl and ZZ4 intake thirsty anyone? ill be pouring gas outta my exhaust pipes! nah not really its only a 650 edelbrock carb
     
  3. DesertDueler

    DesertDueler 1/2 ton status

    Joined:
    May 23, 2001
    Posts:
    3,106
    Likes Received:
    0
    Location:
    Phoenix, AZ
    My 10 second race car gets 7.75 MPG on the freeway at 65 mph, and about 5 in the city, guess it is time to put the A/C back in it. I can always trow a hitch on my firebird /forums/images/graemlins/grin.gif

    Dan
     
  4. rampage

    rampage 1/2 ton status

    Joined:
    Mar 20, 2001
    Posts:
    2,259
    Likes Received:
    72
    Location:
    Humboldt/Pacifica, CA
    That's pretty good /forums/images/graemlins/eek.gif I think monster trucks get 4 GPM so you're catching up to them. What kind of MPG do you get without towing?
     
  5. DesertDueler

    DesertDueler 1/2 ton status

    Joined:
    May 23, 2001
    Posts:
    3,106
    Likes Received:
    0
    Location:
    Phoenix, AZ
    When I first got my truck a couple of months ago it got about 14 mpg, not it is getting just under 10. It is driving me crazy, I am looking into a Ram Jet 502, same MPG, but 510 hp instead of 250.

    Dan
     
  6. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,977
    Likes Received:
    189
    Location:
    Roy WA
    First off, how much is your speedometer wrong? Never discount that as being a MAJOR source of MPG miscalculations. Tire size is almost never as advertised, has the tranny ever been changed, have the gears been changed, etc.

    If this was done with GPS ignore the above /forums/images/graemlins/smile.gif However, it can't be overemphasized that mileage HAS to be measured correctly for MPG to be computed accurately.

    Two of the most important things to check are plugs and wires. Short of that, on a stock setup, completely worn out engine or carb problems are going to be the only things that will make a "huge" difference in MPG in my experience.

    I fixed my distributor with sticky mechanical advance, rebuilt the carb, made sure all the plugs were clean, gapped them differently for testing, and so on, but nothing made a huge difference in MPG (and driveability) like changing out bad plug wires. You expect something like mech. advance to really wake up the truck when it's "bad", but it just didn't make enough difference to notice.

    Of course, I'm getting 18MPG freeway in optimal circumstances, but very little of that is some trick I've performed. (and yes, that MPG was BEFORE I fixed the advance weights, didn't change afterwards) The only real thing I spent any time on was the primary rods/jets in the carb, and only messed with those because the carb wasn't set up for this engine, and was surging at cruise. Not trying to start a "my truck gets XX MPG" thread, because it's been done to death, but just letting you know whats possible, and people that are getting much worse than that on a fairly stock setup, well, somethings not right.
     
  7. Shorts

    Shorts 1/2 ton status

    Joined:
    Oct 16, 2001
    Posts:
    336
    Likes Received:
    0
    Location:
    CC & SA, Tx
    hmm sounds like your truck has the same syndrome mine has /forums/images/graemlins/angryfire.gif i've been chasing the problem forever and still can't find it!

    i'm only getting 9mpg on the hwy /forums/images/graemlins/eek.gif i changed:

    plugs, cap, rotor, fuel filter, cleaned air filter, tranny fluid and filter, both diff fluids, fuel system treatment, checked brakes for stickies, tires inflated properly, ignition module........... uhhhhhhhgggggggggg! /forums/images/graemlins/confused.gif still the same result.

    other things to look at replacing/checking: O2 sensor, EGR, cat, ignition coil, ect sensor /forums/images/graemlins/rolleyes.gif
     
  8. DesertDueler

    DesertDueler 1/2 ton status

    Joined:
    May 23, 2001
    Posts:
    3,106
    Likes Received:
    0
    Location:
    Phoenix, AZ
    My speedo is less than 5 mph off. My truck came with 3.73s and 31s. All I did was put 33s on it. PLugs are pretty new and so are the wires. The engine is no worn out that I know of, it doesnt smoke or burn oil. I have TBI since it is a 87, so no sdvance in the dist. Anbody else?

    Dan
     
  9. 89K1500Chevy

    89K1500Chevy 1/2 ton status

    Joined:
    Nov 9, 2002
    Posts:
    645
    Likes Received:
    0
    Location:
    Georgia, Fayetteville
    [ QUOTE ]
    other things to look at replacing/checking: O2 sensor, EGR, cat, ignition coil, ect sensor

    [/ QUOTE ]
    Yeah the EGR could be clogged up if it has not been replaced in while check it for vacume and also check the PCV.
     
  10. 89K1500Chevy

    89K1500Chevy 1/2 ton status

    Joined:
    Nov 9, 2002
    Posts:
    645
    Likes Received:
    0
    Location:
    Georgia, Fayetteville
    yeah man check this out I have 3.73 gears/33's/TH350 tranny swap and my speedo is DEAD ON Go figure idk how but it is perfect! And also the Knock sensor on our TBI controls the timing advance and retard for the dist.
     
  11. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,977
    Likes Received:
    189
    Location:
    Roy WA
    [ QUOTE ]
    Knock sensor on our TBI controls the timing advance and retard for the dist.

    [/ QUOTE ]

    It doesn't control advance, it "tells" the system to retard the timing when it hears knock.
     
  12. sdavid

    sdavid 1/2 ton status

    Joined:
    Aug 5, 2002
    Posts:
    244
    Likes Received:
    0
    Location:
    Livingston, TX
    Check your exhaust. Make sure your convertor is not clogging up or baffle in muffler has colapsed and stopped it up. Sounds like something has been steadily getting worse. What about your compression? Do you have a cylinder going bad or head gasket?
     
  13. rampage

    rampage 1/2 ton status

    Joined:
    Mar 20, 2001
    Posts:
    2,259
    Likes Received:
    72
    Location:
    Humboldt/Pacifica, CA
    Or a hole in your gas tank /forums/images/graemlins/eek.gif /forums/images/graemlins/rotfl.gif /forums/images/graemlins/rotfl.gif
     
  14. 89K1500Chevy

    89K1500Chevy 1/2 ton status

    Joined:
    Nov 9, 2002
    Posts:
    645
    Likes Received:
    0
    Location:
    Georgia, Fayetteville
    hmm sounds good to me but it turns out my TPS has gone bad Yet agin damn [naughty word] wth i mean i have already replaced this damn thing like 3 times in like 8 months Im really thinking bout going to that 4 bbl intake but one prob i see is the brake booster vac line where it hooks up on the intake.
     
  15. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,977
    Likes Received:
    189
    Location:
    Roy WA
    You tested the TPS to make sure it's good?

    Wrong thread for this though.
     
  16. DesertDueler

    DesertDueler 1/2 ton status

    Joined:
    May 23, 2001
    Posts:
    3,106
    Likes Received:
    0
    Location:
    Phoenix, AZ
    TPS is good. I did a compression test on it and with the motor cold and with no oil on the rings(sat for a day) all cylinders had 160 psi. No hole in the gas tank. As for the exhaust the muffler is an almost new flowmaster with a stock cat. I am going to cut the cat out and try that next, but it is driving me crazy. Also I just put in a new set of plugs today since they are cheap and didnt change a thing.

    Dan
     
  17. big pappa b

    big pappa b 3/4 ton status

    Joined:
    Jan 3, 2003
    Posts:
    6,328
    Likes Received:
    0
    Location:
    Falcon, Colorado
    You sure someone didn't steal some of your gas /forums/images/graemlins/thinking.gif
     
  18. DesertDueler

    DesertDueler 1/2 ton status

    Joined:
    May 23, 2001
    Posts:
    3,106
    Likes Received:
    0
    Location:
    Phoenix, AZ
    I am sure someone didnt steal my gas.

    Dan
     
  19. Thunder

    Thunder 3/4 ton status

    Joined:
    Jul 20, 2000
    Posts:
    8,946
    Likes Received:
    1
    Location:
    Northeast Nevada
    I am going to ask the usual question.
    Have you checked for trouble codes?
    You definatly have something wrong. Bad O2 sensor will give terrible gas milage. Clogged convertor, coolant temp sensor, bad MAP, ECM in limp home mode are all causes of bad MPG.
    Are you also having loss of power?

    Just for comparison I just got back from a fishing trip. Towed my 18 foot boat. Went 260 miles on the interstate at 65 to 70 mph on 16 gals of gas. Yes I tow in overdrive and my spedo is right on. That works out to around 16 mpg. My milage drops off when I am in the mountains or have a head wind but I usually get no worse than 13- 14 mpg average towing my boat.
    350 TBI, 700r4, with 80K on the clock 3.73 gears, 31" tires.
     
  20. DesertDueler

    DesertDueler 1/2 ton status

    Joined:
    May 23, 2001
    Posts:
    3,106
    Likes Received:
    0
    Location:
    Phoenix, AZ
    No trouble codes. I own a snap on scanner and hooked it up to check everything. All looks good. About a month and a half ago I replaced the o2 because it set a code, I foud out that it shook loose, but replaced it anyways. temp sensor is good. The only things I think I am going to try next is another set of new wires, and remove the cat and go from there.

    Dan
     

Share This Page