Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Bad vibes at higher speeds. Possibly alignment?

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Paxx, Feb 25, 2004.

  1. Paxx

    Paxx 1/2 ton status

    Joined:
    Feb 9, 2003
    Posts:
    1,405
    Likes Received:
    0
    Location:
    All Over Western Canada
    When I hit about 75 km/h I start to get some vibration that seems to be coming from the front end. It gets worse if I try to speed up any faster, to the point where I already shook loose a rad mount.

    Is this my alignment? Tire pressure is even, and this is a newly developed problem. Any help would be welcomed.

    Thnx
    ~Max
     
  2. 85scottsdale

    85scottsdale 1/2 ton status

    Joined:
    Dec 22, 2003
    Posts:
    283
    Likes Received:
    0
    Location:
    Lewisville, NC
    Possibly you threw off a wheel weight?
     
  3. 4xcrazy

    4xcrazy 3/4 ton status

    Joined:
    Oct 31, 2003
    Posts:
    9,471
    Likes Received:
    5
    Location:
    Olympia/Lacey, Washington
    My lower ball joints are bad and i get this similar shaking, and extreme tire wear too. floating steering, ok, maybe not quite the same as yours,,,, /forums/images/graemlins/grin.gif
     
  4. rcpilot

    rcpilot 1/2 ton status

    Joined:
    Feb 22, 2002
    Posts:
    507
    Likes Received:
    0
    Location:
    Central Cali
    Like teh above folks stated, check balancing weights, get the truck on a jack/lift and check for loose balljoints, tie-rods and wheel bearings. If all checks then check your frame right behind the steering box to see if it's cracked, also check steering gear and drag link for play.
    Have you recently hit a curb or something??
     

Share This Page