Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

base timing setting 5.7l

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by 1badv10, Mar 8, 2004.

  1. 1badv10

    1badv10 Registered Member

    Joined:
    Feb 26, 2004
    Posts:
    74
    Likes Received:
    0
    Location:
    new york
    my truck has had an engine change from 5.0-5.7, the base timing setting for the 305 is 0 degrees (i think).. is this the same for a TBI 350? I put a performance CPU chip in and im getting detonation at WOT w/ 93 octane and a 160 thermostat, so i just wanted to verify the base timing before i yank the chip out.... /forums/images/graemlins/thinking.gif thanks...
     
  2. big83chevy4x4

    big83chevy4x4 3/4 ton status

    Joined:
    Mar 22, 2002
    Posts:
    6,587
    Likes Received:
    0
    Location:
    Sheridan, Michigan
    i know on carbed it is 4 for 305 and 6 for 350 /forums/images/graemlins/dunno.gif i would adjust the timing till it goes away
     
  3. BurbinOR

    BurbinOR 3/4 ton status

    Joined:
    Feb 17, 2000
    Posts:
    5,829
    Likes Received:
    0
    Location:
    Oregon
    Base for my '91 TBI 5.7 is 0* also. Might your compression be higher than stock? Is your knock sensor working (can you scan it and tell)?
     
  4. southernspeed

    southernspeed 1/2 ton status GMOTM Winner

    Joined:
    Dec 24, 2003
    Posts:
    4,395
    Likes Received:
    50
    Location:
    VA
    [ QUOTE ]
    Base for my '91 TBI 5.7 is 0* also. Might your compression be higher than stock? Is your knock sensor working (can you scan it and tell)?

    [/ QUOTE ]
    Ditto that info. /forums/images/graemlins/thumb.gif
     
  5. Hossbaby50

    Hossbaby50 3/4 ton status

    Joined:
    Sep 1, 2001
    Posts:
    8,972
    Likes Received:
    0
    Location:
    Peoria, AZ
    I would look into making sure the knock sensor is ok. It shouldn't knock. The computer should retard the timing as soon as it detects pings.

    Harley
     
  6. 4X4HIGH

    4X4HIGH 1 ton status Premium Member GMOTM Winner

    Joined:
    Dec 14, 2001
    Posts:
    22,060
    Likes Received:
    69
    Location:
    Pleasanton, CA.
    Did you make sure you disconnected the tan (EST) wire before setting base timing?
     
  7. 1badv10

    1badv10 Registered Member

    Joined:
    Feb 26, 2004
    Posts:
    74
    Likes Received:
    0
    Location:
    new york
    thanks guys 0 degrees it is.. checked the timing this morning its set to 5-6.. really wish i could find my damn distributor wrench /forums/images/graemlins/doah.gif . but being advanced plus the cpu chip is advancing it more.... im going to put the 5.7 knock sensor, and a heated o2 sensor in this week, it may run as good as it did before i started f#@king w/ the performance mods /forums/images/graemlins/whistling.gif again thanks guys
     

Share This Page