Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

battery charger and battery issues

Discussion in 'The Garage' started by TheBlazerKid, Dec 10, 2002.

  1. TheBlazerKid

    TheBlazerKid 1/2 ton status

    Joined:
    Apr 26, 2000
    Posts:
    259
    Likes Received:
    0
    Location:
    Raymond, Washington
    ok for some reason the optima yellow top in my blazer always goes dead. even if it only sets for 5 days or so. but thats not my problem right now. blazer has been sitting for about a month (being painted) and like an idiot I had'nt been starting it every once in awhile so i went to put the charger on it, small NAPA trickle charger, and the guage just pegs for like 2 seconds then goes to zero, pegs, zero. so on and so forth. why is it doing this? is my battery shot? I thought these were good battery's?! /forums/images/graemlins/1zhelp.gif /forums/images/graemlins/1zhelp.gif /forums/images/graemlins/1zhelp.gif
     
  2. Sandman

    Sandman 3/4 ton status Author

    Joined:
    Apr 15, 2002
    Posts:
    5,653
    Likes Received:
    0
    Location:
    Pocatello, ID
    Try unhooking the battery cable and then hooking up the charger. Sounds like there is a current drain in the electrical system somewhere. The 2 amp charger is putting out all it can and not sensing any resistance, is reseting itself. If it charges fine with the battery unhooked from the system, You get the joy of finding the electrical problem. If it still does not, Suspect the battery. Good luck.
     

Share This Page