Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

battery or starter?

Discussion in 'The Garage' started by bryguy00b, Jan 9, 2004.

  1. bryguy00b

    bryguy00b 3/4 ton status

    Joined:
    Apr 7, 2002
    Posts:
    5,587
    Likes Received:
    0
    Location:
    Rochester, N.Y
    well the truck started doing this this week.,.,go to start it and it barly cranks..reall sluggish..i figure ok the battery is getting drained from the cold or w/e..(its liek 14 below here) but once it was warmed up it would restart fine....and its charging fine...but this mouring it started cranking slowly..then eventually i cant get nothin more out of it...instead it just clicks..not like one click but like ..over and over. im guessing just battery..but im asking cause its fricken cold as hell and to cold to go out and fool with it unless i know what it is. just kind of wierd though started doing it right this week...i never had a problem starting it in the cold..but liek i said could just need a battery..
     
  2. Waxer

    Waxer 1/2 ton status Author

    Joined:
    Feb 17, 2000
    Posts:
    1,857
    Likes Received:
    0
    Location:
    Long Beach, CA.
    I agree, sounds like a bad battery to me. Yank it out and have it checked...
     
  3. 76bronco

    76bronco Registered Member

    Joined:
    Oct 25, 2003
    Posts:
    19
    Likes Received:
    0
    Location:
    okc,ok
    sounds just like you said... the battery. IF your connections are still clean and tight. turn your headlights on then turn the key to the start position. if your lights dont dim its more than likely the starter. if they go out or almost out its more than likely the battery
     
  4. bryguy00b

    bryguy00b 3/4 ton status

    Joined:
    Apr 7, 2002
    Posts:
    5,587
    Likes Received:
    0
    Location:
    Rochester, N.Y
    yea..im a dumb ass for even asking..cause now that i think of it the lights drained big time when it started doing it...the only thing that put me of was the clicking sound...cause my starter made a simaler sound when it went out...and started cranking really slow to..but anyway..i ran out and through it in my s-10 and sure enough its the battery /forums/images/graemlins/smirk.gif
     
  5. rjfguitar

    rjfguitar 3/4 ton status GMOTM Winner

    Joined:
    Aug 28, 2002
    Posts:
    9,096
    Likes Received:
    144
    Location:
    california
    If it makes a continual clicking sound like a turning ratchet then it is either a bad ground or not enough power getting to the starter. I had ground problems after I put my 406 in and the starter would do that. Figured out how the ground is supposed to be ran and perfect after that. Also if I leave my system on for more than 10 mins. or so it will just click because the battery is drained.

    I would check your grounds first but since it will fire up after it is warm and after being charged good by the alt., then I would say your battery is having a hard time holding power.
     

Share This Page