Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

battery went dead!

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by JimmyJuneau, Aug 23, 2002.

  1. JimmyJuneau

    JimmyJuneau 1/2 ton status

    Joined:
    Apr 11, 2001
    Posts:
    811
    Likes Received:
    0
    Location:
    Juneau, Alaska
    Ok I drove to work this morning and had no problems at all I went to go to lunch and the first turn of thekey the battery was dead. I have never had any problems at all with this battery since I bought it with the truck about 3/5 years ago. Does anyone have any ideas why it wnet dead Its an ac delco.
     
  2. mudhog

    mudhog THEGAME Staff Member Super Moderator

    Joined:
    Nov 6, 2000
    Posts:
    17,899
    Likes Received:
    2
    Location:
    portland oregon
    could be any number of things could be the battery finnaly gave out could be somthing left on could be that the alternatore went out or it could be a wire shorting out
     
  3. mudhog

    mudhog THEGAME Staff Member Super Moderator

    Joined:
    Nov 6, 2000
    Posts:
    17,899
    Likes Received:
    2
    Location:
    portland oregon
    oh or it could be as simple as the conection is lose or bad or the battery posts need to be cleaned
     
  4. OneInTheSun

    OneInTheSun 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    160
    Likes Received:
    0
    Location:
    Pittsburgh, PA
    Mine just up and died the other day with no warning either. Go to leave the auto parts store and nothing. Talk about a convenient coincidence.

    Sorry, I'm no help as usual. Just thought I'd share. /forums/images/icons/grin.gif
     

Share This Page