Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Battery wont hold a charge

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by chvyblzr1977, Jul 23, 2002.

  1. chvyblzr1977

    chvyblzr1977 Registered Member

    Joined:
    Jul 18, 2001
    Posts:
    83
    Likes Received:
    0
    Location:
    Pissburgh,pa
    I have a 77 blazer 350 4x4 of course and my other battery died so i bought a new one and i went to get it inspected well he had siting over the weekend and he said it wouldnt start the battery was dead.We jumped it i took it home drove it everyday never had a problem then i let it sit for 2 days and again the battery was discharge and body know what is wrong.I have a cd player going to the postive side of the battery and that it.
     
  2. four_by_ken

    four_by_ken 1/2 ton status

    Joined:
    Jun 9, 2001
    Posts:
    3,806
    Likes Received:
    0
    Location:
    Allenton, MI
    Must be a drain somewhere on it. Or else just a bad battery.

    Ken H.
     
  3. Overkill

    Overkill 1/2 ton status

    Joined:
    Jan 15, 2002
    Posts:
    284
    Likes Received:
    0
    Location:
    Orlando, Florida
    Pull the positive cable off and put an ammeter between the cable (that you just pulled off) and the positive battery post. If you read anything over a few milli-amps you have something draining your battery while the truck is off. If you get nothing it's likely a bad battery. Good luck...
     
  4. chvyblzr1977

    chvyblzr1977 Registered Member

    Joined:
    Jul 18, 2001
    Posts:
    83
    Likes Received:
    0
    Location:
    Pissburgh,pa
    Hey thanks for the info ill get a ammeter tommorow and see what happens.
     

Share This Page