Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

big engine trouble

Discussion in 'The Garage' started by adamforsythe, Jul 26, 2005.

  1. adamforsythe

    adamforsythe 1/2 ton status

    Joined:
    Oct 16, 2004
    Posts:
    1,394
    Likes Received:
    0
    Location:
    Maine
    Well a few months ago I pulled my engine to put chrome and paint on it. Well I got it back in the truck and I have been playing around with it ...hooking this up hooking that up, etc. Well a few days ago I put carb cleaner in the gas tank for the hell of it. Then yesterday I started the truck up to see how she ran. The engine rocks. But then it started to ping really bad I have no idea what is going on. I moved the dizzy around but nothing really happens. It just started to do it. Now it is hard to start the truck up.
    What is going on? This is a new engine in my book. There is only 10,000-15,000 miles on it. I am the only one that has owned the engine.
    Thanks
    Adam
     
  2. Chaddy

    Chaddy 1/2 ton status GMOTM Winner

    Joined:
    May 23, 2005
    Posts:
    4,110
    Likes Received:
    2
    Location:
    Salt Lake City,Utah
    did you replace you fuel filter, hoses. fuel pressure,mabey put premium down the intake? why did you put that in your tank???????
     
  3. adamforsythe

    adamforsythe 1/2 ton status

    Joined:
    Oct 16, 2004
    Posts:
    1,394
    Likes Received:
    0
    Location:
    Maine
    Hey the only mods I did to the fuel system was a edelbrock fuel filter that I installed at the first of this year. I did not put a lot of the carb cleaner in the tank. There was only about 1/3 of the bottel left.
    The engine shakes like a S.O.B in fact the whole truck shacked now. There is a lot of pinging going on in the engine. It sounds like the engine is camed with the biggest cam that can be put in a 350.
    Thanks
    Adam

     
  4. anjieandjohn

    anjieandjohn Registered Member

    Joined:
    Oct 31, 2004
    Posts:
    61
    Likes Received:
    0
    Location:
    Virginia Beach
    Shake, rattle, and roll

    Did you check the plugs? Maybe something got through the filter and fouled the plugs...I know I have had 2 plugs over the last 8 months foul due to me needing to do a valve job and my truck runs like butt....like a huge miss. Just a thought...
     
  5. Mad-Dog

    Mad-Dog 1/2 ton status

    Joined:
    Mar 20, 2005
    Posts:
    548
    Likes Received:
    0
    Location:
    Ocklawaha,Fl
    Drain the tank, carb and fuel lines completely........
    refill the tank fire the engine and don't do that again.
    The ONLY thing you wanna pour in the tank or run thru the carb is gasoline........ :bow:
     
  6. adamforsythe

    adamforsythe 1/2 ton status

    Joined:
    Oct 16, 2004
    Posts:
    1,394
    Likes Received:
    0
    Location:
    Maine
    I am going to go through the whole Ignition system today. I have a felling that a few of my plug wires are shot.
    Thanks
    Adam

     
  7. ecameron87

    ecameron87 1/2 ton status

    Joined:
    Nov 9, 2002
    Posts:
    115
    Likes Received:
    0
    Location:
    AZ, Tucson
    Dirty fuel

    Was it a full tank of gas with just 1/3 of cleaner? I have heard that the stuff you put in the gas tank does a great job of cleaning of junk from the walls of the tank and sends crap through the fuel pump (sometimes ruining it) then cloggs up the fuel filter. Some particles can even get into the engine. I would start with pulling the fuel filter to see if that is the case. From what the engine is doing, you could have some clogged jets or fouled plugs. Also check the basics. Is the engine getting fuel? Spark?

    Good Luck
     

Share This Page