Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

BIG PROBLEM!!!

Discussion in '1969-1972 K5 Blazer | Truck | Suburban' started by Big Red, Jun 15, 2003.

  1. Big Red

    Big Red 1/2 ton status

    Joined:
    Jan 9, 2003
    Posts:
    250
    Likes Received:
    0
    Location:
    Bristol, CT
    hey all. i really need help on this one. I think i chipped sum teeth off my spider gears in teh back. thing pops a few times as i get goin. its only under load though, like on qa hill or if i give it a wee bit more gas. If anyone has any ideas as to what it may be, please! tell me! and if anyone lives in connecticut with a spare Corp 10bolt diff, PM me, i just might buy it. /forums/images/graemlins/frown.gif
     
  2. Big Red

    Big Red 1/2 ton status

    Joined:
    Jan 9, 2003
    Posts:
    250
    Likes Received:
    0
    Location:
    Bristol, CT
    i also just realized this is in the wrong forum, o well.
     
  3. jasonkh2tg

    jasonkh2tg 1/2 ton status

    Joined:
    Mar 27, 2003
    Posts:
    139
    Likes Received:
    0
    Location:
    MPLS MN
    pop the diff cover off and look...you will never know until you can do a good visal inspection...It might even be low on fluid...but in any event you will never know tell you can look in there and see....and while your in there look at the ring & pinion for wear....
     
  4. Big Red

    Big Red 1/2 ton status

    Joined:
    Jan 9, 2003
    Posts:
    250
    Likes Received:
    0
    Location:
    Bristol, CT
    i really wish i could pull the whole thing out and rebuild it(i had the original wipers, so the guy b4 me didn't do squat to it) but ur right. i guess i was hopin for sumone who had a similar problem. /forums/images/graemlins/crazy.gif /forums/images/graemlins/k5.gif
     
  5. rrent

    rrent 1/2 ton status

    Joined:
    Jun 10, 2001
    Posts:
    174
    Likes Received:
    0
    Location:
    Round Rock, Texas
    Is your rear a posi (limited slip or what have you) -- if so it can make a pretty heavy clunk when taking off especially when you are turning --- caused by clutch material in the fluid. This is real common on Corvettes -- I could actually feel my car move side to side in time with the clunks when taking off and think the previous owner made the mistake of thinking this was a high dollar fix when he decided to sell. I sucked the old fluid out and replaced with GM fluid and limited slip additive --- drove it in big figure 8's and then drained and refilled again. No problems since.

    good luck
     
  6. Big Red

    Big Red 1/2 ton status

    Joined:
    Jan 9, 2003
    Posts:
    250
    Likes Received:
    0
    Location:
    Bristol, CT
    nope, just a reg open diff. /forums/images/graemlins/frown.gif. i wish it was posi. /forums/images/graemlins/thumb.gif /forums/images/graemlins/k5.gif
     

Share This Page