Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Blazer doesnt start

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by protechk5, Oct 1, 2004.

  1. protechk5

    protechk5 1/2 ton status

    Joined:
    Sep 26, 2004
    Posts:
    2,015
    Likes Received:
    0
    Location:
    VA
    I havent been driving my blazer that much lately, and the battery has been dead for awhile. But i would start it up every now and then by using a jumper. But today when i went out to try and start it, with the jumper it wouldnt start! /forums/images/graemlins/confused.gif Nothing, no clicks or anything, i tried using another truck to jump it but still nothing. Is my battery just too f ed to start it even while being jumped? Or could it be something else like my starter or something?? When i have the jumper on the battery, like the indside lights come on until i turn the key. Any info will help, thanks a head of time
     
  2. Adub

    Adub 1/2 ton status

    Joined:
    Aug 16, 2002
    Posts:
    106
    Likes Received:
    0
    Location:
    OK
    Sounds like the battery is shot
     
  3. bottomfeeder

    bottomfeeder 1/2 ton status

    Joined:
    Mar 9, 2004
    Posts:
    277
    Likes Received:
    0
    Location:
    Oklahoma City
    Sounds like the terminal cables are shot too.
     
  4. protechk5

    protechk5 1/2 ton status

    Joined:
    Sep 26, 2004
    Posts:
    2,015
    Likes Received:
    0
    Location:
    VA
    yeah it was just the battery thanks
     

Share This Page