Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Blazer shaking

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by 90K5, Aug 11, 2000.

  1. 90K5

    90K5 1/2 ton status

    Joined:
    Jun 1, 2000
    Posts:
    3,719
    Likes Received:
    0
    Location:
    Lubbock, TX
    I already posted this but my Blazer shakes violently at highway speeds. Today I got my tires balanced and it still shakes just as bad. What else could it be? Balljoints? This is really annoying and I hate it that nothing ever works the first time I fix it or get it fixed.

    90K5
     
  2. James

    James 1/2 ton status

    Joined:
    Jun 22, 2000
    Posts:
    179
    Likes Received:
    0
    Location:
    Castaic, Ca
    Ujoints? Mine just went out on the freeway. Shook violently
    James
     
  3. 90K5

    90K5 1/2 ton status

    Joined:
    Jun 1, 2000
    Posts:
    3,719
    Likes Received:
    0
    Location:
    Lubbock, TX
    I hadn't thought about that. I just looked in my Haynes manual and it said it might be the wheel bearings or loose or out of adjustment suspension parts.

    90K5
     
  4. SAVAGE1

    SAVAGE1 1/2 ton status

    Joined:
    May 22, 2000
    Posts:
    1,104
    Likes Received:
    0
    Location:
    BAY AREA, CA
    I just got the Blazer back from my Uncle's garage. It would start to shake at around 35 and it would get worse on the freeway. Got the tires re-balanced but still some vibration. So we replaced the ball joints and it runs smooth now. Hope this helps.



    BLAZE IT UP!!!
     
  5. tRustyK5

    tRustyK5 Big meanie Staff Member Super Moderator GMOTM Winner Author

    Joined:
    Jul 23, 2000
    Posts:
    36,163
    Likes Received:
    1,360
    Location:
    E-town baby!
    Mine used to shake from 45-65 Mph. I got the tires re-balanced, replaced the shocks all around, then while I was rotating the tires I noticed the tread was pretty cupped on one front tire. The lower ball joint on passenger side was shot. I replaced all my ball joints and the vibration is gone. [​IMG]

    Rene 81 Jimmy,350,SM465/NP205,FF14 bolt,HD Dana 44,3.73's,4"susp.,35"Grabber MT's,body in progress
     
  6. TheBlazerKid

    TheBlazerKid 1/2 ton status

    Joined:
    Apr 26, 2000
    Posts:
    259
    Likes Received:
    0
    Location:
    Raymond, Washington
    mine shook like a bugger from the front end becuase one of the disk rotors was warped, just a suggestion

    Your right I dont understand the jeep thing!?
     
  7. riz

    riz 3/4 ton status

    Joined:
    Mar 7, 2000
    Posts:
    6,026
    Likes Received:
    0
    Location:
    Wisconsin
    Check your front seals....if one is bad it will allow dirt and grime to get into your axle shafts. This happened to me once and when I took out my short axle shaft it had a cupped groove in it. I replaced it for next to nothing and while I was at it I also did new bearings and races. After that I could take her up over 90 mph and it was as smooth as a baby's a$$.



    L8r,

    .Riz.
     
  8. fr8train

    fr8train 1/2 ton status

    Joined:
    Aug 2, 2000
    Posts:
    1,712
    Likes Received:
    0
    Location:
    Maryland
    This could be one too. If you have bashed the rig on the trai,l your drive shaft may have lost some weights and have become imbalanced. Though I would be leaning more toward your U-joints like the rest of the pack here. IS it under throttle or just rolling?
     
  9. Ressurection

    Ressurection 1/2 ton status

    Joined:
    May 9, 2000
    Posts:
    360
    Likes Received:
    0
    Location:
    Prairie du Sac, Wisconsin
    Also, check to make sure your tranny housing bolts (to the engine block) are tight. My dad's 73 had loose bolts, and it shook like a sonofabitch. We tightened them as best we could, but the heads of some were embedded into the housing aluminum from the vibration. It made 100% difference. Good luck!

    You can't beat going Topless!
     
  10. James

    James 1/2 ton status

    Joined:
    Jun 22, 2000
    Posts:
    179
    Likes Received:
    0
    Location:
    Castaic, Ca
    Ressurection has a good point. I pulled my tranny last week and the two lower bolts on each side of bell housing were very lose. Me old 73k5 has so many damn shakes, rattles. vibes, shimmies, etc would of never noticed until the freaking tranny fell out lol. OH well its a chevy.
    Peace
    James
     
  11. Mine is doing about the same thing right now (from about 50-75). When I let off the accelerator, I can hear the vibrating slow (like a slowing spinning), rattle a little, and then it stops (even while I am still moving). I have outside tread wear on my front tires. I did check my driveshaft and it didn't seem to be moving laterally too much (not enough to cause a vibration). Anyone have ideas between front ball joints and U-joints?
     

Share This Page