Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Blinker stopped Blinking.

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by spencerjw, Apr 29, 2002.

  1. spencerjw

    spencerjw Registered Member

    Joined:
    Oct 6, 2001
    Posts:
    75
    Likes Received:
    0
    Location:
    Highlands Ranch, CO
    Ok, so I have an 86K5 Silverado. The other day my right blinker stopped blinking. When I click over to it is stays lit and that's it. When checking around the vehicle I noticed that all my lights work and the only thing that I can see that's different is that my right front side marker turns OFF when the blinker is on. Without the blinker on it's lit like it should be. So, with that in mind I know it's not the bulb in there (I took it apart to check anyway and it seams to be fine). However, the left blinker works just fine so I know it's also not the flasher fuse.

    All lights are working correctly except for that one little side marker, and that's only when the blinker is turned on.

    Any ideas???
     
  2. thatK30guy

    thatK30guy 1 ton status Premium Member

    Joined:
    Jan 12, 2001
    Posts:
    32,076
    Likes Received:
    55
    Location:
    .
    Add some more blinker fluid to it. /forums/images/icons/wink.gif
     
  3. spencerjw

    spencerjw Registered Member

    Joined:
    Oct 6, 2001
    Posts:
    75
    Likes Received:
    0
    Location:
    Highlands Ranch, CO
    Hm, didn't see that coming from a mile away or anything. /forums/images/icons/wink.gif
     
  4. SCOOBYDANNN

    SCOOBYDANNN 1/2 ton status

    Joined:
    Sep 4, 2001
    Posts:
    2,131
    Likes Received:
    27
    Location:
    El Paso, TEXAS
    Damn---you beat me to it Wes/forums/images/icons/laugh.gif
     
  5. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,982
    Likes Received:
    191
    Location:
    Roy WA
    Yet another cause to determine exactly what the turn indicators do when a certain fault is happening : )

    Obviously a problem on the left side, I'd start by swapping one bulb at a time across. If the side marker is "dying" though, I'd check the turn signal bulbs (under grille too?...Ouch) first. If its neither of those (or at least the rear, easy to get to one /forums/images/icons/smile.gif
    Check the other bulbs as well. Swapping them side to side one at a time has worked for me in the past, as I've had bulbs that appear good (filament appeared intact) but didn't actually work.
     
  6. UseYourBlinker

    UseYourBlinker 1 ton status

    Joined:
    Jun 7, 2000
    Posts:
    11,117
    Likes Received:
    0
    Location:
    .
    Change the bulbs,and flasher..
     
  7. blazentank

    blazentank 1/2 ton status

    Joined:
    Apr 18, 2001
    Posts:
    426
    Likes Received:
    0
    Location:
    Houston, Texas
    Mine 86 just did the same thing change the flasher fuse thing under the dash in the fuse box it is the bottom right round one cost like $2 Hope that helps if that is not the solution check the bulbs
     
  8. spencerjw

    spencerjw Registered Member

    Joined:
    Oct 6, 2001
    Posts:
    75
    Likes Received:
    0
    Location:
    Highlands Ranch, CO
    Thanks, I'll try that. I figured that since the left worked the flasher wasn't bad, but I guess that could easily be the problem.

    thanks agian, I'll try that tomorrow.
     
  9. NoSmog73

    NoSmog73 1/2 ton status

    Joined:
    Sep 28, 2001
    Posts:
    2,348
    Likes Received:
    0
    Location:
    lodi,ca
    I thought the same thing and change the flasher and it worked then .....
     

Share This Page