Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Blower motor relay?

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Liberator, Nov 15, 2001.

  1. Liberator

    Liberator 1/2 ton status

    Joined:
    Jul 16, 2001
    Posts:
    276
    Likes Received:
    0
    Location:
    Communist California
    My blower motor stopped working. Just wondering if it could be something other than the relay? Controls inside the dash? Can't even find a stinkin fuse for it. That fuse slot is empty, no wiring! Any help would be appreciated.

    Bo

    If it breaks, it wasn't good enough!
    http://coloradok5.com/gallery/liberator
     
  2. Can Can

    Can Can Pusher Man Staff Member Super Moderator

    Joined:
    Feb 17, 2000
    Posts:
    15,552
    Likes Received:
    136
    Location:
    Cochrane, Alberta, Canada
    I hate to tell you this, but it sounds like your fan motor bit the big one. The same thing has happened to me in the past with two different rigs, and both times it ended up being the fan motor itself. The only good news I have is that replacing it is a cinch.........



    <font color=blue> NEVER FORGET, NEVER FORGIVE, NEVER SURRENDER<font color=blue>
     
  3. Confederate9

    Confederate9 1/2 ton status

    Joined:
    May 29, 2000
    Posts:
    1,686
    Likes Received:
    0
    Location:
    Greensboro NC
    yeah i replaced mine last week. it took like 20minute or maybe less. and the thing was only 15.99 @ adv auto

    <font color=red>K5: Because size DOES matter</font color=red>
    85 K5 4IN LIFT 35 GOOD YEAR WRANGLER MT/R, AMERICAN RACING WHEELS
     
  4. Liberator

    Liberator 1/2 ton status

    Joined:
    Jul 16, 2001
    Posts:
    276
    Likes Received:
    0
    Location:
    Communist California
    Thanks for the reply.
    The blower motor works fine when I wire it to the battery.

    Bo



    If it breaks, it wasn't good enough!
    http://coloradok5.com/gallery/liberator
     
  5. Mr.Chevy4x4

    Mr.Chevy4x4 1/2 ton status

    Joined:
    Jun 16, 2000
    Posts:
    1,932
    Likes Received:
    0
    Location:
    Sims, NC
    Check the ground strap on it. It bolts to the plastic housing and therefore has to have a good ground strap to function. If it is there and the motor runs when wired directly to the battery then I would say it is definitely the relay. I had one go bad on me this summer. Easy to replace but cost more than the blower motor! Good luck!

    '85 K5 : Run it til it breaks, then fix it and go again!
     
  6. ftn96

    ftn96 1/2 ton status

    Joined:
    Sep 26, 2000
    Posts:
    3,238
    Likes Received:
    0
    Location:
    Nashville Tn
    Ok dude, I just went thorugh all this. I replaced the motor first, no dice. Then I replaced the switch in the dash, no dice. Then I replaced the fan speed resistor, no dice. Then bigbad82k5 stopped by one day adn he took a little screw driver and some sand paper and clean the contacts up on the relay (little gadget mounted on the cindensor coil housing) and the SOB has been working ever since.

    Surgeon General's Warning:
    Viagra and steroids may be harmful to your spouse![​IMG]
    <a target="_blank" href=http://www.nashvillek5.freeservers.com>www.nashvillek5.freeservers.com</a>
     
  7. TXBIGFISH

    TXBIGFISH 1/2 ton status

    Joined:
    Oct 2, 2001
    Posts:
    297
    Likes Received:
    0
    Location:
    Sachse TX
    Had the same problem. Went to O'Rielley and bought a new relay, the one that mounts on the condenser housing, and have not had a problem again. I think it was $20. Try that before hacking itno everything else. I did the same thing with the motor and jumping it to the battery and it was good too. If you have a voltmeter, see if you have power to the relay, I'm not sure what color the wire was but it was the biggest one going to it, it should be hot. Let us know what happens.

    &lt;*)))&gt;&lt;

    81" GMC Jimmy.............stock for now!

    IT'S A DOG EAT DOG WORLD OUT THERE, AND I'M WEARING "MILK BONE" UNDERWEAR!!!!!!!!
     
  8. ftn96

    ftn96 1/2 ton status

    Joined:
    Sep 26, 2000
    Posts:
    3,238
    Likes Received:
    0
    Location:
    Nashville Tn
    Yeah, but I had 12 volts going through the purple wire going to the blower motor and it still wouldn't come on. It was really mind boggling to me. But Im far from undstanding the mystic powers of electricity.

    Surgeon General's Warning:
    Viagra and steroids may be harmful to your spouse![​IMG]
    <a target="_blank" href=http://www.nashvillek5.freeservers.com>www.nashvillek5.freeservers.com</a>
     
  9. TXBIGFISH

    TXBIGFISH 1/2 ton status

    Joined:
    Oct 2, 2001
    Posts:
    297
    Likes Received:
    0
    Location:
    Sachse TX
    Yeah, the purple wire, that's it. I had power to it too but the motor would not run, I "hot wired the fan motor to the battery and It would run. It's the relay if that is happening, I know this because I am now riding in toasty warmth. Can't wait till spring when I don't need it anymore and I can remove the top until next winter!

    &lt;*)))&gt;&lt;

    81" GMC Jimmy.............stock for now!

    IT'S A DOG EAT DOG WORLD OUT THERE, AND I'M WEARING "MILK BONE" UNDERWEAR!!!!!!!!
     

Share This Page