Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Body mount trouble

Discussion in '1969-1972 K5 Blazer | Truck | Suburban' started by skyblazer, Jul 10, 2002.

  1. skyblazer

    skyblazer 1/2 ton status

    Joined:
    Oct 1, 2000
    Posts:
    209
    Likes Received:
    0
    Location:
    Houston, TX
    Well after about six months of driving on new rubber body mounts, things are starting to sag without the top on. The doors are starting to bind and the door seams are no longer parallel. I tried shimming the mount under the door which helped a little, but now I have to adjust the front fender/door alignment. Anyone found any great fixes for this problem? Thanks in advance. /forums/images/icons/confused.gif
     
  2. Robin

    Robin 1/2 ton status

    Joined:
    Oct 30, 2001
    Posts:
    184
    Likes Received:
    0
    Location:
    Georgetown, Texas
    Thats bad news for me, since putting new body mounts on, really triggered the whole FOR exercise (did I do all that for 6mo. of a straight body???).

    I assume your rocker boxes are in good shape?
     
  3. chulisohombre

    chulisohombre 1/2 ton status

    Joined:
    Apr 11, 2002
    Posts:
    4,141
    Likes Received:
    14
    Location:
    Bangor,Pa
    i redid mine with polyurethane.99 dollars for the set.no problems yet.
     
  4. ryanNC

    ryanNC 1/2 ton status

    Joined:
    Dec 7, 2000
    Posts:
    182
    Likes Received:
    0
    Location:
    North Carolina, Valdese
    i also did the poly route and haven't had any problems for 5 years.
     
  5. skyblazer

    skyblazer 1/2 ton status

    Joined:
    Oct 1, 2000
    Posts:
    209
    Likes Received:
    0
    Location:
    Houston, TX
    Well, maybe I'll start tearin stuff apart again, but I think I'll try shimming the middle mounts up again. My rocker boxes are in great shape, but I've heard of guys on the forumns using 3 x 3 square tubing for support instead of the boxes. Anyone have more details and/or pictures?
     

Share This Page