Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Body Mounts

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by ColAdo82K5, May 10, 2000.

  1. ColAdo82K5

    ColAdo82K5 1/2 ton status

    Joined:
    Feb 18, 2000
    Posts:
    789
    Likes Received:
    0
    Location:
    MO
    hey,
    Tell me about your bodies !! body mounts that is. Factory ones still in good shape ? need new ones ? What type did you get to replace them ? did you replace them yourselves ? how much $$ is involved ? Tell Me !!! thanks
    Colonel Ado
     
  2. Burt4x4

    Burt4x4 3/4 ton status

    Joined:
    Feb 17, 2000
    Posts:
    6,854
    Likes Received:
    0
    Location:
    California (Modesto area)
    When I first got my rig in 93 one of the first things I did was the body mounts. After I got the rig home and started going thru it(first Blazer ever..) I found out of the 12 mounts only 5 were still connected to the frame[​IMG]!!
    I said HO MY G** what the..... I could just see it the body comming off the frame! That day I got a set of Poly body mounts from Energey Suspension. I did one mount at a time and use a bottle jack to lift the area I was working on.
    One of the carrige bolts was just rattling in the hole for so long it looked like a sharpend piencle.[​IMG] Anyway after completeing the upgrade w/all new bolts gotten from HWare store, WOW what a smooth/quiet ride it turned into! No more creaking banging rattling WOW!! I highly recomend going thru your mounts with new harware and if you go with poly get the 'black' mounts they are impregnated (sp?) with graphite and help with the 'poly squeek' syndrome!!
    Good luck!

    Rock ON![​IMG] 72 K5 [​IMG] Led Zeppelin
     
  3. BIGJ

    BIGJ 1/2 ton status Author

    Joined:
    Feb 17, 2000
    Posts:
    896
    Likes Received:
    0
    Location:
    Central Arkansas
    My rig had been neglected for so long I was in the same boat as Burt4x4. Half of the bolts were missing. The first time I took it off road the body flexed more than the suspension. For example: The fan shroud would rub against the fan when the front end got crossed up, at factory height, no body lift, and that's when I realized that the bolts in the front were missing. Needless to say my bud thought it was pretty funny. I got all new bolts and poly body bushings. It was an afternoon install, no big deal really. The polyurethane bushing kit was about 100 bucks. Definitely worth the money.

    BIGJ
     

Share This Page