Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

brake help again, they still suck

Discussion in 'The Garage' started by muddybuddy, Apr 25, 2006.

  1. muddybuddy

    muddybuddy 3/4 ton status

    Joined:
    Jan 29, 2004
    Posts:
    8,933
    Likes Received:
    1
    Location:
    Fairfax Station VA
    alright ive got 60/14b with 4wheel disc's and 42's. i tried the stock master cyinder and i had no brakes. i put in a master cylinder from a k30 w/o hydroboost, and now i have brakes, but they are not good by any means. what are my options now? is a p-valve going to solve my problems, or is there something else? im going to be installing new extended ss lines for the front, but i dont think that will make a difference. any help would be great.
     
  2. wraenking

    wraenking 1/2 ton status

    Joined:
    Apr 30, 2003
    Posts:
    1,493
    Likes Received:
    0
    Location:
    Toms River, NJ
    i got a new p-valve from inline tube (www.inlinetube.com) i think.

    my breaks have been fine since day one. a couple of others have used them with great results also. its only aroun 75-85 bucks, but well worth it. i bought the adjustbale valve and never even used it. spend the extra money and do it right.

    good luck.
     
  3. muddybuddy

    muddybuddy 3/4 ton status

    Joined:
    Jan 29, 2004
    Posts:
    8,933
    Likes Received:
    1
    Location:
    Fairfax Station VA
    well the problem is, im not getting near enough brake power to even worry bout locking up the tires, i pretty much have to push it to the floor to get it to stop. i bench bled it and everything.

    the k30 master cylinder i have on it now has a blow rear seal, so im going to be returning it, so i'm lookin for the biggest possible master cylinder. i ordered the p30 with 4wheel disc master, but the resovoir would hit the brake booster and wouldnt bolt up right. how are you guys able to run the p30 master with the stock booster? what part number are you using? ive tried a couple different ones but there is always interference????
     

Share This Page