Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Brake issues? master cyl bad possibly?

Discussion in 'The Garage' started by broncoman6524, Dec 4, 2006.

  1. broncoman6524

    broncoman6524 1/2 ton status

    Joined:
    Oct 31, 2005
    Posts:
    2,469
    Likes Received:
    0
    Location:
    chuluota Fl
    i bled my brakes tonight bc before i could push the petal to the floor and it would stop but crappy. now it will lock the tires up but it stil goes to the floor. and if you hit it once then again quickly it is REAL easy to push and goes straight to the floor...would this be my Master cyl going bad..or could i have a leak in my sys or what?

    btw its an 84 k5 stock 1/2tons
     
  2. AZ79K5Project

    AZ79K5Project 1/2 ton status

    Joined:
    Jan 15, 2006
    Posts:
    2,082
    Likes Received:
    0
    Location:
    Arizona
    Here is a page I found two days ago relating to the same type of issue: LINK
    This write-up is about some import or something but the idea is the same.

    It sounds like a bad MC. When was the last time you cleaned the system (fluid flush)?

    MC are CHEEEEAP. I bought one for mine today. $18.00 (+core) most places for my 79.
     
  3. broncoman6524

    broncoman6524 1/2 ton status

    Joined:
    Oct 31, 2005
    Posts:
    2,469
    Likes Received:
    0
    Location:
    chuluota Fl
    ive got the whole thing from another k5 mastercyl and vac booster. from a 90 taht i may just swap over. but thanks that was what i was thinking too. and i havent entirely flushed the sys. ive only had the truck a year. the fluids brown though...
     
  4. AZ79K5Project

    AZ79K5Project 1/2 ton status

    Joined:
    Jan 15, 2006
    Posts:
    2,082
    Likes Received:
    0
    Location:
    Arizona
    I just did an axle swap on mine, flushed the brake system, new calipers, new brake cylinders, new braided lines up front. Now I can't get brake pressure. Peddle goes to the floor. I've bled the s**t out of the system.

    I was going to change the MC today, but I picked up tubing to make my own bench bleed steup. I didn't get both sizes of fittings. Hopefully tomorrow I'm going to R&R the MC. I hope to get the thing running for a trip in a couple of weeks.

    The brake issue is a PITA:mad:
     

Share This Page