Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Brake Light gremlin driving me crazy!!

Discussion in 'The Garage' started by Derf00, Dec 6, 2005.

  1. Derf00

    Derf00 1/2 ton status

    Joined:
    Jul 25, 2000
    Posts:
    1,683
    Likes Received:
    0
    Location:
    Abilene, TX
    If I don't solve this problem soon, I am going to take a BFH and beat the s*** out of something.

    From time to time my left brake light will quit working. If I use the use the left turn signal, the brake light will go back to working. When the brake light fails, the turn signal and the emergency lts continue to work. I suspect the problem is in the turn signal switch, but even though the switch has been replaced, the problem continues.

    Any suggestions??
     
  2. 83suburbman

    83suburbman Registered Member

    Joined:
    Oct 4, 2005
    Posts:
    13
    Likes Received:
    0
    Location:
    Vancouver WA
    Sorry no suggestions because mine do'es the same thing exactly!
     
  3. Leper

    Leper 1/2 ton status

    Joined:
    Feb 18, 2005
    Posts:
    4,437
    Likes Received:
    0
    Location:
    Dallas Baby!!!!
    There is a loose ground at that taillight. Exact same thing happened to a buddy.
     
  4. daleearnhardt01

    daleearnhardt01 1/2 ton status

    Joined:
    Aug 29, 2002
    Posts:
    3,223
    Likes Received:
    2
    Location:
    Richmond, VA
    Yup same thing happened to me, redid all the grounds and all was well...
     
  5. muddyblzr

    muddyblzr 1/2 ton status

    Joined:
    Nov 2, 2004
    Posts:
    623
    Likes Received:
    0
    Location:
    houston/san antonio texas
    ahhh finally im having the exact same problem. now i just gotta find the sucker
     
  6. hack500

    hack500 1/2 ton status

    Joined:
    Sep 16, 2005
    Posts:
    523
    Likes Received:
    0
    Location:
    Templeton, Ma
    I had a bad bulb and my truck did that.
     
  7. Roz

    Roz 1/2 ton status

    Joined:
    Mar 27, 2005
    Posts:
    900
    Likes Received:
    0
    Location:
    San Diego
    could be bulb going out, ground or just dirty/corroded connections
     
  8. readymix

    readymix 3/4 ton status

    Joined:
    May 30, 2004
    Posts:
    6,706
    Likes Received:
    26
    Location:
    Murrieta, California
    look at the ground prong in the socket for that light. I'll bet it si broken off at the bend.
     
  9. Leper

    Leper 1/2 ton status

    Joined:
    Feb 18, 2005
    Posts:
    4,437
    Likes Received:
    0
    Location:
    Dallas Baby!!!!
    IIRC there is a ground wire in that area that comes loose/gets corroded.
     
  10. 90blzr

    90blzr 1/2 ton status

    Joined:
    Mar 25, 2001
    Posts:
    3,027
    Likes Received:
    0
    Location:
    SO CAL
    not sure if anyone else has mentioned this yet:D :wink1: .......
    but I may be a bad ground:eek1:
     
  11. Robert D

    Robert D 1/2 ton status

    Joined:
    Oct 2, 2005
    Posts:
    261
    Likes Received:
    0
    Location:
    Austin, TX
    I'm going to have to check this also, my brake light does the same thing.
     
  12. jims505

    jims505 Registered Member

    Joined:
    Apr 14, 2004
    Posts:
    19
    Likes Received:
    0
    Location:
    SO CAL
    If all else fails change your flasher unit.
     

Share This Page