Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Brake Lights and Turn Signals

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by senatorwoodhouse, Jun 21, 2005.

  1. senatorwoodhouse

    senatorwoodhouse 1/2 ton status

    Joined:
    Jan 22, 2005
    Posts:
    108
    Likes Received:
    0
    Location:
    des moines, IA 50311
    So I knew that my turn signals didn't work, but one of my friends was backing my 81 k5 out of the driveway the today and I noticed that I have no brake lights. :crazy: I have had this problem with older k5's that the button thta is actuated by the pedal gets pushed over. But upon searching for this easy fix I was dissapointed to find no such luck. Are the brake lights operated by a pressure switch? If so where would this unit be located? Anyone else had problems like these?
     
  2. senatorwoodhouse

    senatorwoodhouse 1/2 ton status

    Joined:
    Jan 22, 2005
    Posts:
    108
    Likes Received:
    0
    Location:
    des moines, IA 50311
    Oh yeah I also might want to put in the obvious...the bulbs are ok
     
  3. Muddytazz

    Muddytazz 1 ton status

    Joined:
    Jun 30, 2002
    Posts:
    20,073
    Likes Received:
    0
    Location:
    Salem, Or.
    The switch on the pedal is the only switch. Might want to check your ground at the back end behind the housing.
     
  4. wicked87_k5

    wicked87_k5 1/2 ton status

    Joined:
    Aug 9, 2004
    Posts:
    235
    Likes Received:
    0
    Location:
    Little Falls,NJ... North
    I had the same problem on both of my K5's 77 & 87 . turned out to be melted wires, drivers side frame rail between the rear tire and the bumper.
     
  5. senatorwoodhouse

    senatorwoodhouse 1/2 ton status

    Joined:
    Jan 22, 2005
    Posts:
    108
    Likes Received:
    0
    Location:
    des moines, IA 50311
    Just the stupid button got pushed back away from the pedal. That stupid thing is waaaaaaaaay up the pedal. what a pain to bend back. :cool1: Thanks for the help everybody.
     

Share This Page