Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Brake lights? help?+cops

Discussion in 'The Garage' started by 82K5_6.5L, Feb 15, 2006.

  1. 82K5_6.5L

    82K5_6.5L 1/2 ton status

    Joined:
    Dec 4, 2002
    Posts:
    439
    Likes Received:
    0
    Location:
    Tucson, Az
    a little long, but bear with me..
    OK guys i need ur help! last nite, my old mans transmission took a crap in his 81. so i of course had to tow his heavy ass home. everything was going great, the load was probably around 11,000lbs because he had his work trailer attached to his truck (81 3/4ton 4x4) so we get home everything is good. i unhook the straps and take off down the road. not but 10 minutes into my trip down the road i get pulled over. cop says i have no rear lights at all! no brakes, no running lights, no turn signals or license plate light?? im thinking wtf? i just towed a truck across town and everything was fine. so the gay ass cop sights me for "Operating on moving vehicle in unsafe condition" and "No taillights" i had no idea these were not working until i was pulled over. they worked when i was towing, i couldnt figure it out? i didnt get a fix-it-ticket or anything. just a ****ing ticket to go directly to court. on top of it, he made me park the K5 at my moms place around the corner. i had no tools but a 5in1 pocket knife. i finally got the brake lights and turn signals to work but no running lights. might as well put a big neon sign on my truck that says pull me over! i spent 2 hours last nite after i got it home, checking fuses, tracing wires, this and that!?? could anybody tell me y i have no running lights and my dash lights are dead too..

    help CK5! :confused:
     
  2. 82K5_6.5L

    82K5_6.5L 1/2 ton status

    Joined:
    Dec 4, 2002
    Posts:
    439
    Likes Received:
    0
    Location:
    Tucson, Az
    nobody?
     
  3. BranndonC

    BranndonC 3/4 ton status

    Joined:
    Mar 18, 2002
    Posts:
    8,591
    Likes Received:
    0
    Location:
    Anaheim, Ca
    wire you didnt see? Bad ground?
     
  4. K10ANDYKHAMNIC

    K10ANDYKHAMNIC 1/2 ton status

    Joined:
    Sep 17, 2001
    Posts:
    1,962
    Likes Received:
    0
    Location:
    Western CO
    did ya check the fuses for continuity ?
     
  5. BigOrange90Jimmy

    BigOrange90Jimmy 1/2 ton status Premium Member

    Joined:
    May 24, 2002
    Posts:
    2,923
    Likes Received:
    0
    Location:
    Wilmington, NC
    It sounds like the headlight switch itself may have gone bad.
     
  6. supericeboy

    supericeboy Registered Member

    Joined:
    Jan 25, 2006
    Posts:
    5
    Likes Received:
    0
    Location:
    Marshall, VA
    Maybe the headlight switch?
     
  7. George_Pimpdaddy

    George_Pimpdaddy 1/2 ton status

    Joined:
    Oct 17, 2002
    Posts:
    1,306
    Likes Received:
    1
    Location:
    Edmonton Alberta Canada
    the tail light assembly fuse i think its called that anyways besides that might be time to go over the wiring
     

Share This Page