Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Brakes Rubbing?

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Logan, Sep 20, 2000.

  1. Logan

    Logan Registered Member

    Joined:
    Feb 17, 2000
    Posts:
    93
    Likes Received:
    0
    Location:
    Fournier, Ontario, Canada
    It's been about a month since I got my new rims put on (alloys), and I noticed last night that I was missing a lugnut from the right rear rim. I put another one on, and tightened up the rest, checking all the wheels. The front two rims were locked down solid, but all the lugs on the back were kinda loose.

    After re-tightening the back ones, I've noticed that my left rear brakes sound like they're rubbing. This doesn't seem possible, but could I have over-tightened a lugnut and damaged something? I did it by hand, and they're still not as tight as the nuts on the front wheels.

    Any ideas? Everything was fine until I tightened it back up.
     
  2. Goose

    Goose 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    1,127
    Likes Received:
    1
    Location:
    South Central Kansas
    Sounds like they just ran the rear lug nuts on by hand and forgot to torque them down. About your left rear, I can't think of how you could have hurt anything. If it sounds like your brakes are rubbing, check them.
     

Share This Page