Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Burned My LockRight!!!!!

Discussion in 'The Garage' started by jimmyjack, Aug 5, 2002.

  1. jimmyjack

    jimmyjack 1/2 ton status

    Joined:
    May 11, 2000
    Posts:
    2,290
    Likes Received:
    0
    Location:
    Tucson Az
    My lockright started making some really horrible noises yesterday afternoon. Cruching, popping, snapping.... I was able to get it home, barely. Don and I removed the locker and the left side was trashed pretty bad. It wasn't worn flat, but the edges were worn badly and catching each other and making the noises. Soooooooooo..... how is LockRight about their warrantees? It's only 5 months old and hasn't been abused. Please tell me it's gonna be OK, and they'll warrantee it. /forums/images/icons/wink.gif
     
  2. BorregoK5

    BorregoK5 1/2 ton status

    Joined:
    Sep 7, 2001
    Posts:
    2,457
    Likes Received:
    0
    Location:
    San Marcos, Ca USA
    What did you have it in ? Front / Rear d44/60/12-14bolt? I'm still looking for a front d60 locker and this was one on the list.
     
  3. jimmyjack

    jimmyjack 1/2 ton status

    Joined:
    May 11, 2000
    Posts:
    2,290
    Likes Received:
    0
    Location:
    Tucson Az
    Rear 10 bolt. Stock motor, stock 3.73 gears, 33" tires. It's a ratchet type, gear on gear locker and I expect it to wear, but not like this. I've heard alot of good things about them and seen good things and done stuff I couldn't imagine doing without it. Just bad luck I think. I'll let you know what I think after I get word back from them.
     
  4. HarryH3

    HarryH3 1 ton status Author

    Joined:
    May 31, 2000
    Posts:
    10,384
    Likes Received:
    2
    Location:
    Georgetown, TX
    I've seen lockrites fail within hours of installation. And they were installed by a guy that does it for a living, so I tend to doubt the installation was the problem. /forums/images/icons/shocked.gif

    Insert music here: Queen's "Another One Bites The Dust" /forums/images/icons/cool.gif
     
  5. jimmyjack

    jimmyjack 1/2 ton status

    Joined:
    May 11, 2000
    Posts:
    2,290
    Likes Received:
    0
    Location:
    Tucson Az
    Yer killin' me Harry! I doubt it was the installation. I did it by the book. Like I said it's 5 months old and it suddenly started clanging really badly. So, hopefully it'll all work itself out. Luckily I still have the old spider gears /forums/images/icons/smirk.gif
     
  6. SkulzNBonz

    SkulzNBonz 1/2 ton status

    Joined:
    Feb 20, 2002
    Posts:
    4,522
    Likes Received:
    0
    Location:
    OKC, Oklahoma
    I've heard they are really good about there warranty. I think somebody else here just got their's replaced under warranty.

    John
     
  7. Robbie6987

    Robbie6987 1/2 ton status

    Joined:
    Jul 16, 2002
    Posts:
    111
    Likes Received:
    0
    Location:
    killeen TX
    Could be bad luck, also check out your 10 bolt make sure none of your axle bearings are bad i have a 12 bolt with 16-35 boggers with a lock right and im pretty rough on it and ive had no probs been running it for about 7 months.
     
  8. jimmyjack

    jimmyjack 1/2 ton status

    Joined:
    May 11, 2000
    Posts:
    2,290
    Likes Received:
    0
    Location:
    Tucson Az
    Going by the amount of noise this made I think I'll at least replace the outer bearings. It was horrible.
     

Share This Page