Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Can my Battery Cause these Problems

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by 78Blazer, Feb 17, 2001.

  1. 78Blazer

    78Blazer 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    873
    Likes Received:
    0
    Location:
    Michigan
    Ok I have been working on my 84 m1009 when I got it most of the wiring under the hood was gone. So I got to looking at what was left and it pretty much looked like my 78s harness so I swapped it in there in place. Now when I turn the key over few light in the dash come on and I can turn the blower on wipers on etc.. But I I try to turn it over no go and my headlight brakes etc. dont work either. So now I am wondering if my new battery that sat for over 1 yr is not holding enough charge to run the lights and turn it over or is the wiring not right from the 78 to 84? Just seems everything else would work right with it since my wipers blower all that work right.

    Scott
    78blazer
     
  2. tRustyK5

    tRustyK5 Big meanie Staff Member Super Moderator GMOTM Winner Author

    Joined:
    Jul 23, 2000
    Posts:
    36,173
    Likes Received:
    1,385
    Location:
    E-town baby!
    Weren't the m1009's all 24 volt? Does it still have the deisel?

    Rene

    [​IMG]
     
  3. 78Blazer

    78Blazer 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    873
    Likes Received:
    0
    Location:
    Michigan
    yes they were diesel, But i have swapped motor trans tcase all from my 78 into it. It now has a 400 in it.


    Scott
    78blazer
     
  4. Blazer_Boy

    Blazer_Boy 1/2 ton status

    Joined:
    Dec 16, 2000
    Posts:
    1,669
    Likes Received:
    0
    Location:
    Sioux City, IA, USA
    It sounds like your harness is not wired up. If you're lights arent even working then something is not getting a connection. If the batterty were kaput you'd probably get at least a little click when you tried to roll it over. Check all your connections and grounds. Something probably isn't hooked up.

    June 2001 - The Texas Sawz All masacre begins. Be afraid rust, be very afraid. [​IMG]
     
  5. Cmoe

    Cmoe 1/2 ton status

    Joined:
    Feb 19, 2000
    Posts:
    2,884
    Likes Received:
    0
    Location:
    Mesa,AZ
    I found that the wiring harnesses for under the hood were defferent between the '78 and the '87 that I did the swap with... If you get a manual you can check the way that the wires should be and wire them the way they should be done... Or you can take the fuseblock out of the '78 and installl it in the new body. Did your '78 come with emission or was it an excemp model? Don't tell the state that it doesn't have the diseal is gone or you may have to add a cat and other emissions.

    C'moe

    <font color=black>the blazer is "Back in Black"
     
  6. 78Blazer

    78Blazer 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    873
    Likes Received:
    0
    Location:
    Michigan
    My 78 didnt have them either. Im not worried about it we dont have any kind of testing or anything here in Michigan so not a big deal.

    Scott
    78blazer
     
  7. DieselDan

    DieselDan 1/2 ton status

    Joined:
    Jan 27, 2001
    Posts:
    1,056
    Likes Received:
    0
    Location:
    Vermont
    CUCVs where a 12V/24V system. Only the starter, glowplug (power, not sensor), blackout lights, & radio mount was 24V, everything else 12V. The dual (isolated ground) altenators each recharged one battery.

    Now, is the black-out light switch still functioning, is it in the drive (upper) position? Are you using a 12V starter? Are you using the CUCV bus bars on the fire wall? The starter should be pretty easy to trouble shoot, but a cobbed harness can be a bear.

    Hope you don't mind if a bemoan another diesel blazer (CUCV at that) converted to gas hog!
     
  8. 78Blazer

    78Blazer 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    873
    Likes Received:
    0
    Location:
    Michigan
    I have the starter figured out and will have the lights soon none of the stuff mentioned is being used. I am doing this swap becuase I bought the truck completely stripped. No motor intereior trans tcase doors top etc..

    Scott
    78blazer
     

Share This Page