Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Carb Problem ?

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Chevit, Jan 16, 2002.

  1. Chevit

    Chevit 1/2 ton status

    Joined:
    Dec 10, 2001
    Posts:
    1,492
    Likes Received:
    0
    Location:
    dnaltroP, nogerO
    I have a rebiult Q-Jet purchased in Feb. My newest problem is lack of power. I was towing my trailer last weekend and I could not get going over 55 mph. I thought that maybe I had gotten some bad gas so i dumped in some gas drier and carb cleaner pulled in the drive way and power braked it, and the blazer just stumbled and almost died then a nice big cloud of black smoke. The thing that puzzels me is that it will run fine one day and the next it will not run for sh1t. Any ideas


    84 K5, Crate 350, 700r tranny, 3.73 rear, 32 11.50 15, Q-jet
     
  2. 1bigk10

    1bigk10 1/2 ton status

    Joined:
    Dec 20, 2001
    Posts:
    151
    Likes Received:
    0
    Location:
    Medford Oregon
    Check timing? Readjust air/feul mixture? Try running Premium? Check plugs If all black way to rich, if all white to lean, if kinda golden just about right. Check plug gap?

    Happy Wheelin.[​IMG]

    1982 K10 Silverado. [​IMG] 327 SHPE powerplant SM465/205,15"custom lift 38.5"TSL/SWAMPERS 12boltrearD44 front,3.73 gears.
     
  3. TorkDSR

    TorkDSR 1/2 ton status

    Joined:
    Sep 1, 2001
    Posts:
    1,258
    Likes Received:
    0
    Location:
    bucks co pa
    try changing both gas filters, the one in th carb, and the one in line(if you have one) you could also check your hei and see if everythings ok, look for massive carbon deposits etc.

    beligerence doesn't justify intelligence.
    <font color=blue>wheelers hate posers.</font color=blue>
    <font color=red>79k15/400/700r4/205/38.5</font color=red>
     
  4. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,979
    Likes Received:
    189
    Location:
    Roy WA
    Cat converter being plugged can cause problems with higher speed/loss of power. On/Off poor running coul dbe timing, I just dealt with that, really rich running sometimes, other times fine. Distributor components were ALL messed up, haven't had probs since I "rebuilt" the top end of the distributor. Can't hurt to go in and check out the cap, rotor, mechanical advance, as well as checking for spark and fouled plugs.

    Dorian
    My tech/links page: <a target="_blank" href=http://www.dorianyeager.com/index2.html>www.dorianyeager.com/index2.html</a>
    Why insist on counting when the ring gear has the tooth counts stamped in?
     
  5. Chevit

    Chevit 1/2 ton status

    Joined:
    Dec 10, 2001
    Posts:
    1,492
    Likes Received:
    0
    Location:
    dnaltroP, nogerO
    The cat is only 4-5 months old I will check the distributer that is the only thing on this rig that has not been replaced.
    Thanks for the replies

    84 K5, Crate 350, 700r tranny, 3.73 rear, 32 11.50 15, Q-jet
     

Share This Page