Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Carb Problem

Discussion in 'The Garage' started by 89Jimmy, Jun 27, 2003.

  1. 89Jimmy

    89Jimmy 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    192
    Likes Received:
    0
    Location:
    Northern N.Y. east end of Lake Ontario
    Hello,
    I 've got a drivability problem with my '85. 350, truck avenger carb, edelbrock performer intake, MSD dist. & ignition box. Carb was new Feb 03. It's been running great. I ran out of gas today,(while next in line at the pump.) Pushed the truck up and filled up. It started slow, as you'ld expect. But would not idle. I had to start it while holding the throttle about 3/4 open. Acted flooded. It was running very poorly and I wasn't far from home so I got a ride and went back 3 or 4 hours later. The truck was cold by then and would idle, but not good. By the time I got home,( about 5 minutes), it would stall at idle and blew black exhaust, (choke smoke), at 3000 rpm. Would not run under 2500-3000. I tapped the carb, thinking a stuck float. No difference. Ideas? Thanks in advance.
    John
     
  2. florida4x4

    florida4x4 1/2 ton status

    Joined:
    Sep 9, 2002
    Posts:
    255
    Likes Received:
    0
    Location:
    Florida
    sounds like trash got sucked into the carb. get a gasket set and pull the bowls, clean it out throughly and be sure to put a good filter on the fuel line..
     
  3. 89Jimmy

    89Jimmy 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    192
    Likes Received:
    0
    Location:
    Northern N.Y. east end of Lake Ontario
    I've got an stock chevy efi filter inline, but I'm willing to try anything. Is the cleaning just in the float bowls or also metering plates ? I don't know much about carbs.
    John
     
  4. 89Jimmy

    89Jimmy 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    192
    Likes Received:
    0
    Location:
    Northern N.Y. east end of Lake Ontario
    Checked further this morning. When I crank the engine gas pours out of the vent tube. Float stuck? Thanks.
    John
     
  5. blasterD

    blasterD 1/2 ton status

    Joined:
    May 24, 2003
    Posts:
    410
    Likes Received:
    0
    Location:
    Anchorage Alaska
    You are correct sir. /forums/images/graemlins/thumb.gif /forums/images/graemlins/thumb.gif
     

Share This Page