Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Chasing Your Tail-Venting with a guessing game

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Nonesuch, Nov 19, 2001.

  1. Nonesuch

    Nonesuch 1/2 ton status

    Joined:
    Jul 16, 2001
    Posts:
    1,467
    Likes Received:
    0
    Location:
    Austin(Leander), TX
    This probably isnt the place for this post but I have to see how smart all my compadres are!

    The K5 has been running bad! She has a few electrical shorts! On occasion she stumbles and stutters and looses power when the throttle is held constant(accel. and high RPM). Items i have been chasing are: vacuum leaks, bad coil, tailight grounds, starter cable, battery ground, carb tuning, and other odds and ends.
    I finally got her fixed up and running good tonight. She wouldnt start this morning when I tried to go to work! Got home and finally figured out the problem!
    Can you guess what it was that was causing all my problems?
     
  2. BlueBlazer

    BlueBlazer 1/2 ton status

    Joined:
    Feb 15, 2001
    Posts:
    1,940
    Likes Received:
    0
    Choke sticking?


    82 K5, 6.2L Diesel, sm465, np205, 14 bolt welded, 8 lug 10 bolt lock right, 410 gears, 35" Mud Kings
    SPEAK SOFTLY AND DRIVE A BIG TRUCK
     
  3. Nonesuch

    Nonesuch 1/2 ton status

    Joined:
    Jul 16, 2001
    Posts:
    1,467
    Likes Received:
    0
    Location:
    Austin(Leander), TX
    nope covered that in the carb tuning area! Please try again! LOL
     
  4. mudhog

    mudhog THEGAME Staff Member Super Moderator

    Joined:
    Nov 6, 2000
    Posts:
    17,899
    Likes Received:
    2
    Location:
    portland oregon
  5. arq

    arq 1/2 ton status

    Joined:
    Jan 17, 2001
    Posts:
    2,017
    Likes Received:
    0
    Location:
    Imperial Valley/Maricopa
    fuel filter

    offroad baja!!!
    72 4x4 CST Blazer
    71 4x4 CST Blazer
    <a target="_blank" href=http://coloradok5.com/gallery/ArqDennis>My Pics</a>
     
  6. 83ZZ502_Jimmy

    83ZZ502_Jimmy 1/2 ton status

    Joined:
    Feb 7, 2001
    Posts:
    3,103
    Likes Received:
    0
    Location:
    Richmond, VA
    I still put my vote on bad grounds, but how about the distributor. I 'll bet it was bad. If not could be the ign. module.

    John



    <font color=blue>"When all else fails, read the instructions, or get a bigger hammer"</font color=blue>
     
  7. Loose wires on the starter itself?

    American by birth, Marine by the grace of God
     
  8. Nonesuch

    Nonesuch 1/2 ton status

    Joined:
    Jul 16, 2001
    Posts:
    1,467
    Likes Received:
    0
    Location:
    Austin(Leander), TX
    Ignition mudule, you got it. I was so mad that this baby has been causing all my electrical problems and poor performance. In all my life I have never seen a GM HEI ign. mod. go bad. Worst part was it died a slow death which really seems wierd. When it finally quit working completely was when i found the problem. Stupid azz ign. mod. I guess you learn something every day though. Well this ended a good month-month and a half saga of tail chasing. But all in all it was kinda fun!
    Justin
     
  9. '73 K5

    '73 K5 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    1,763
    Likes Received:
    0
    Location:
    Kansas
    I've never heard of that. I always thought the modules were either 100% working or totally dead. Good to hear you got it fixed though.

    '73 K5
    Chevy good...Ford bad
     
  10. CaptCrunch

    CaptCrunch 1/2 ton status

    Joined:
    Feb 2, 2001
    Posts:
    3,596
    Likes Received:
    1
    Location:
    Minnesota
    Man I missed the quiz... doh! LOL. It doesn't surprise me... the GM modules are about as goo as the GM injectors and fuel pumps LOL. Basically anytime after 100k you are fair game to get nailed.

    -Mikey
    1987 Chevy K5 Blazer- 350 TBI
    <a target="_blank" href=http://coloradok5.com/gallery/captcrunch>http://coloradok5.com/gallery/captcrunch</a>
     
  11. 83ZZ502_Jimmy

    83ZZ502_Jimmy 1/2 ton status

    Joined:
    Feb 7, 2001
    Posts:
    3,103
    Likes Received:
    0
    Location:
    Richmond, VA
    Yes, I've had several to go south on me. It was on an old engine. It just seemed to eat them. I've never had one to be intermittent like you describe. I'm glad all is working now...

    So what's my prize??[​IMG] LOL. Have a good one!

    John

    <font color=blue>"When all else fails, read the instructions, or get a bigger hammer"</font color=blue>
     

Share This Page