Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

check engine light came on

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by surpip, Nov 10, 2004.

  1. surpip

    surpip 1 ton status

    Joined:
    Apr 7, 2004
    Posts:
    10,877
    Likes Received:
    0
    Location:
    sacramento ca
    while i was goin down the freeway in OD, when i got to my exit, i shut it off and started it again, and it turend off and diddent come on again all the way to work........Any ideas? It has done it before, (when i first got it)and it would loose alot of power, so i changed the oil and filter and the air filter, and it diddent happen any more. This time when it did it it diddent lose any power at all /forums/images/graemlins/dunno.gif
     
  2. big83chevy4x4

    big83chevy4x4 3/4 ton status

    Joined:
    Mar 22, 2002
    Posts:
    6,587
    Likes Received:
    0
    Location:
    Sheridan, Michigan
    pull a code and tell what code it is.
     
  3. Thunder

    Thunder 3/4 ton status

    Joined:
    Jul 20, 2000
    Posts:
    8,946
    Likes Received:
    1
    Location:
    Northeast Nevada
    Here.s a link on how to check codes:http://www.troublecodes.net/GM/
    Your ALDL connector is on the bottom of the dash under the steering wheel.
    Find out what code its throwing and post it.
     
  4. surpip

    surpip 1 ton status

    Joined:
    Apr 7, 2004
    Posts:
    10,877
    Likes Received:
    0
    Location:
    sacramento ca
    ya but the light isent on any more will the code still be there? dumb ass me i should know this crap
     
  5. Thunder

    Thunder 3/4 ton status

    Joined:
    Jul 20, 2000
    Posts:
    8,946
    Likes Received:
    1
    Location:
    Northeast Nevada
    Yes. Anytime the CEL comes on the problem code is stored in the ECMs memory for aprox 50 starts.
     
  6. surpip

    surpip 1 ton status

    Joined:
    Apr 7, 2004
    Posts:
    10,877
    Likes Received:
    0
    Location:
    sacramento ca
    right on ill try to check it this weekend i dont have the time during the week, ill problally get it Thurs Night
    thanks alot,
    dale
     
  7. K5MONSTERCHEV

    K5MONSTERCHEV 1/2 ton status

    Joined:
    Jan 27, 2003
    Posts:
    3,254
    Likes Received:
    0
    Location:
    Castro Valley, CA
    What year is it? What kind of car?
     
  8. surpip

    surpip 1 ton status

    Joined:
    Apr 7, 2004
    Posts:
    10,877
    Likes Received:
    0
    Location:
    sacramento ca
    89 blazer, my truck
     
  9. rescuekrawler

    rescuekrawler Registered Member

    Joined:
    Nov 7, 2004
    Posts:
    28
    Likes Received:
    0
    dealer have the scan tool and it only like 10$ to do it!
     
  10. spearchucker

    spearchucker 1/2 ton status

    Joined:
    Nov 17, 2003
    Posts:
    1,556
    Likes Received:
    0
    Location:
    Bay area, CA
    Most autoparts stores will do it for free. Or a paper clip in the A/B terminals will give you the code too.
     
  11. Adub

    Adub 1/2 ton status

    Joined:
    Aug 16, 2002
    Posts:
    106
    Likes Received:
    0
    Location:
    OK
    Likely an O2 sensor. When they start to go bad, they respond slower. The first place the computer regcognizes that slow repsonse is constant rpm driving on the highway.
     
  12. K5MONSTERCHEV

    K5MONSTERCHEV 1/2 ton status

    Joined:
    Jan 27, 2003
    Posts:
    3,254
    Likes Received:
    0
    Location:
    Castro Valley, CA
    Jump the 2 pins in th eupper right corner, with the key on.
     
  13. btolenti

    btolenti 1/2 ton status

    Joined:
    Sep 28, 2003
    Posts:
    644
    Likes Received:
    0
    Location:
    Gilroy, CA
    Ignition module going bad???? The truck would still run, but with a lot less power.... /forums/images/graemlins/dunno.gif
     
  14. k20

    k20 3/4 ton status

    Joined:
    Sep 9, 2001
    Posts:
    5,068
    Likes Received:
    0
    Location:
    Mineral Springs, NC
    mine throws an EGR code every now and again, whenever I run the interstate at constant speed, just like once a week or so.
     

Share This Page