Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

check engine light on 91 4cyl s10

Discussion in '1983-2005 S-Series models' started by dodgedude99, Oct 6, 2004.

  1. dodgedude99

    dodgedude99 1/2 ton status

    Joined:
    Jul 12, 2003
    Posts:
    784
    Likes Received:
    0
    Location:
    burbia of illinois
    my sons s10
    130k miles, 4cyl 5 speed.
    after the truck has had time to warm up and such, the "check engine" comes on for a few minutes and then goes off, a few minutes later it comes on, and goes off.
    on and off, on and off, etc, etc,.

    i replaced the O2 sensor with a Bosch piece figuring that i had 1 that i didnt put in my K5 yet, and that it could probaly use it, seemed to make sense.

    but that didnt solve the problem.
    i did the onboard test grounding the test port, but it just kept on flashing 13 (which according to the chiltons is everything is normal).

    it has new plugs, wires, cap & rotor.

    gas mileage is kinda crappy, when its revved up when its cold, it spit all kinds of black crap on the house.

    the shady thing is the exhaust, looks like it could use a new one.
    the guy i bought it from is the service manager at the local chevy dealer, and is the cousin of my buddy, he claims that a bad Cat will trip the light, thoughts on that?

    any insight would be appreciated.
    thanks
     
  2. R72K5

    R72K5 Banned

    Joined:
    Mar 5, 2001
    Posts:
    8,905
    Likes Received:
    0
    Location:
    central IL
    get a scanner and run the ECM code flashes, it is inexpensive to buy one at auto zone etc and comes with a thick manual and everything lists all the gm codes, youll have to reset the ecm after replacing a part that you believe may have been causing the code, IE engine light to come on,

    youll most likely end up having to take truck to dealer to plug it in so they can try and find out what component is out of parameters, welcome to the world of ECM controlled vehicle,s it sux when they go bad, thats why i always own old carb fed chevies and not fuel injected junk

    if you get code 12 then its normal, it will flash 12 twice, ignore it ofr its normal it is supposed to flash that code a couple of times, if thats all that it flashes then youre fine, just disconnect battery for a few seconds then reconnect it and drive it and see if light coems back, if so then youve got something out of parameters in the system somewhere, you can use a paper clip or something to check the codes i have a book with them all listed and descriptions just lemme know,

    i forgot which two terminals on the ALDL to jump to make the ECM spill its guts/codes

    its a ground and like #2 i think

    i forget.

    someone here will know


    good luck
     
  3. dodgedude99

    dodgedude99 1/2 ton status

    Joined:
    Jul 12, 2003
    Posts:
    784
    Likes Received:
    0
    Location:
    burbia of illinois
    i actually have a special tool the dude at Autozone gave me, 2 prong thing.
    if your looking on the test port, the 2 that need to be grounded are the upper right 2.
     

Share This Page