Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Clank when starting

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by 77GMC15, Nov 23, 2002.

  1. 77GMC15

    77GMC15 1/2 ton status

    Joined:
    Mar 14, 2001
    Posts:
    110
    Likes Received:
    0
    Location:
    Vacaville, CA
    Just put everything on and when I go to start it there's an ear-shattering clank from near the starter. I checked out the flywheel and it isn't missing any teeth or have any that are trashed, but some of them are silver like they were grinded from the starter or something. Do I have the wrong starter or will this go away if I go all the way to starting it and letting it run?
     
  2. vince13

    vince13 1/2 ton status

    Joined:
    Dec 6, 2001
    Posts:
    105
    Likes Received:
    0
    Location:
    Penticton, BC Canada
    You need to shim your starter. if you bought a new starter it should come with a shim.
     
  3. 77GMC15

    77GMC15 1/2 ton status

    Joined:
    Mar 14, 2001
    Posts:
    110
    Likes Received:
    0
    Location:
    Vacaville, CA
    Oh why thank you mr vince13
     
  4. NITRO

    NITRO 1/2 ton status

    Joined:
    Jan 9, 2002
    Posts:
    1,057
    Likes Received:
    0
    Location:
    Frankfort In
    it shouldnt make a grinding when it engages if it is to close. you should have a 1/8" soace between the starter and flywheel.once u get shims, u'll understand. then just engage your solenoid after u get the shims on and see how it looks. but dont leave it engaged for more than 30 seconds, or it will burn up the solenoid. o yea, its normal if the solenoid doesnt disengage until the truck is started. good luck

    NITRO
     

Share This Page