Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Clicking in front end

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by FL84K5, May 21, 2003.

  1. FL84K5

    FL84K5 1/2 ton status

    Joined:
    Aug 19, 2001
    Posts:
    936
    Likes Received:
    0
    Location:
    Sarasota, FL
    When I'm turning sharply at slow speeds I'm getting a clicking kinda sound coming from the driver side front wheels area. It's a consistent noise, only when turning slow. It does it with the hub locked or unlocked, in 2 or 4 wheel drive. What should I be looking for here?
     
  2. BlazerWheels

    BlazerWheels 1/2 ton status

    Joined:
    Feb 13, 2003
    Posts:
    587
    Likes Received:
    0
    Location:
    California
    I just notices that mine does the same thing. Don't have any help for ya, but will be interested to hear.
     
  3. wraenking

    wraenking 1/2 ton status

    Joined:
    Apr 30, 2003
    Posts:
    1,493
    Likes Received:
    0
    Location:
    Toms River, NJ
    ill take a stab and say its the cv joints possibly. my old car had that problem. since im new to blazers, lets see what others have to say!
     
  4. SkulzNBonz

    SkulzNBonz 1/2 ton status

    Joined:
    Feb 20, 2002
    Posts:
    4,522
    Likes Received:
    0
    Location:
    OKC, Oklahoma
    Ball joints, drag link ends, tie rod ends. Probably not a u joint since it does it with the hubs unlocked.

    John
     
  5. Shaggy

    Shaggy 3/4 ton status

    Joined:
    Dec 15, 2000
    Posts:
    6,737
    Likes Received:
    0
    Location:
    Los Banos, CA
    <font color="green"> Did someone put a playing card in your spokes? /forums/images/graemlins/tongue.gif </font>

    [ QUOTE ]
    ill take a stab and say its the cv joints possibly. my old car had that problem. since im new to blazers, lets see what others have to say!

    [/ QUOTE ]

    <font color="green"> CVs are for IFS junk only, Blazers and other solid axle vehicles do not have them, at least not in the axles. </font>
     
  6. gravdigr

    gravdigr 1/2 ton status

    Joined:
    Apr 15, 2003
    Posts:
    1,129
    Likes Received:
    0
    Location:
    Tyrone, PA
    I just had a problem kinda like this on our flatbed F350 2WD. It was clicking all the time though. Sounded like a rock stuck in the tread. Turned out to the the wheel bearing.
     
  7. wraenking

    wraenking 1/2 ton status

    Joined:
    Apr 30, 2003
    Posts:
    1,493
    Likes Received:
    0
    Location:
    Toms River, NJ
    thanks shaggy. i am new to this, so i take any info i can and store it. lol
     
  8. Pure Insanity

    Pure Insanity 1/2 ton status

    Joined:
    Mar 17, 2001
    Posts:
    4,579
    Likes Received:
    0
    Location:
    Dade City, Florida
    Jason, this will sound stupid, but I dont remember, do you still have the wheel trim on your rims?

    IF you do, pull them off and drive it. Might be a loose clip or a pebble in the ring. Ive seen that one whoop many a tech. It would piss them off when I would walk over, pull the wheel cover off, drop out a pebble and tell them to try it out again. /forums/images/graemlins/rotfl.gif I only knew from way back I seen it happen at a shop and knew to look. /forums/images/graemlins/thumb.gif
     
  9. FL84K5

    FL84K5 1/2 ton status

    Joined:
    Aug 19, 2001
    Posts:
    936
    Likes Received:
    0
    Location:
    Sarasota, FL
    I took the trim rings off a loooong time ago. The funny thing is, it didn't click any today when I drove it. I'm about to pick my sister up from church, so I'll see if it does it then. I'm gonna wear the tires out quick, I like driving the Blazer everywhere vs. the Ranger. /forums/images/graemlins/rotfl.gif
     
  10. Pure Insanity

    Pure Insanity 1/2 ton status

    Joined:
    Mar 17, 2001
    Posts:
    4,579
    Likes Received:
    0
    Location:
    Dade City, Florida
    I thought the rings were gone, but its and idea. /forums/images/graemlins/rotfl.gif
     
  11. rick88blaze

    rick88blaze 1/2 ton status

    Joined:
    Jan 24, 2003
    Posts:
    2,342
    Likes Received:
    1
    Location:
    Knob Noster, Mo.
    check your wheel bearings.
     

Share This Page