Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Clutch problems

Discussion in 'The Garage' started by chris12, Jan 14, 2007.

  1. chris12

    chris12 1/2 ton status

    Joined:
    Apr 23, 2006
    Posts:
    267
    Likes Received:
    0
    Location:
    Forest Ontario, 1/4 hr from Port Huron Michigan
    OK before we started was difficult to get into gear with the clutch only being 2 months old.Replaced the slave with a new one,still no pedal.Replaced the hydrolic line and a master cylinder rebuild kit,still no pedal.At this point the pedal releases only 1/2 inch from the floor.Next we installed a brand new clutch and had the flywheel machined,so now everything is new.Bleed the system again,absolutly no air but still no pedal,truck moves when pedal is only 1/2 in. from floor.This has got us beat ,any ideas.
     
  2. JEBSR

    JEBSR 1/2 ton status

    Joined:
    Dec 23, 2004
    Posts:
    1,541
    Likes Received:
    0
    Location:
    Clarksville, TN
    May sound stupid, but how did you bleed the slave cylinder? If you didn't remove it, you may still have some air at the bottom of the cylinder. The book says to take the mounting bolts off tilt the cylinder down with the bleeder being the highest point and then bleed it. I had similar problems until I did mine that way. No problems since.
     
  3. chris12

    chris12 1/2 ton status

    Joined:
    Apr 23, 2006
    Posts:
    267
    Likes Received:
    0
    Location:
    Forest Ontario, 1/4 hr from Port Huron Michigan
    Great going to try it that way,i did remove the slave but was bleeding it with the bleeder screw being the lowest point.So will tilt it the other way.
     
  4. chris12

    chris12 1/2 ton status

    Joined:
    Apr 23, 2006
    Posts:
    267
    Likes Received:
    0
    Location:
    Forest Ontario, 1/4 hr from Port Huron Michigan
    OK done this thing tilted up ,tilted down,bench bleed and still no pedal.the last time i could not push the pedal down and now the push rod is bent.
     

Share This Page