Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Clutch trouble on a '79 Jimmy

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by bentbranch, Aug 21, 2002.

  1. bentbranch

    bentbranch Newbie

    Joined:
    Aug 21, 2002
    Posts:
    4
    Likes Received:
    0
    Location:
    Vermont
    Clutch trouble on a \'79 Jimmy

    I have a '79 Jimmy with a 350 and a transmission with 1 low gear and 1-3, and reverse (of course). I replaced the clutch,pressure plate, and throw out bearing. It seemed to go pretty smooth but yesterday I was wheeling in the woods and I noticed the clutch seemed to be binding. I crawled underneath and looked at the linkage while a friend pushed the clutch and with the linkage being simple I could see no visible binding. Looking back on the process of installing the throwout bearing I don't recall greasing the shaft before installing the new one. Does anyone have any ideas on what could be causing my trouble.
    ps: The clutch doesn't bind all of the time and is not binding at the same spot in the clutch pedal travel. Sometimes I can shift the tranny with the bind and other times I'm grinding.

    Thanks,
    Bud @ bentbranch
     
  2. 95 Silverado

    95 Silverado 1/2 ton status

    Joined:
    Nov 9, 2001
    Posts:
    467
    Likes Received:
    0
    Location:
    Central PA
    Re: Clutch trouble on a \'79 Jimmy

    It sounds like you have an SM-465 transmission, sometimes the front bearing retainer will wear in the are where the throw-out bearing slides on it to release the clutch, if it wears bad enough it can cause problems. be sure your motor mounts and transmission mount are good, if the engine gets to moving around it can cause binding problems in the linkage, the same goes for body mounts.
     
  3. bentbranch

    bentbranch Newbie

    Joined:
    Aug 21, 2002
    Posts:
    4
    Likes Received:
    0
    Location:
    Vermont
    Re: Clutch trouble on a \'79 Jimmy

    I am unfamiliar with the front bearing retainer. Where is it located? Is it located in the flywheel where the transmission alignment shaft rides? I never had a binding problem until I replaced the clutch. It feels like binding, I'm just not sure where to look.
     

Share This Page