Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Clutch Woes

Discussion in 'The Garage' started by TXsizeK5, Nov 3, 2002.

  1. TXsizeK5

    TXsizeK5 1/2 ton status

    Joined:
    Aug 26, 2001
    Posts:
    2,518
    Likes Received:
    0
    Location:
    College Station, TX
    only somtimes, i push in my clutch and it feels really really... (hard to descibe) but spongy. Its like isntead of being smooth, its real rough and its like it almost like the pedal and whatever its connected to is ribbed. Like when you pull it out it kinda has a real small rough spot, then a real quick smooth, then rough, then smooth, all the way out. And this only happens sometimes. Sorry if i cant describe it any better. Can anyone help or diagnose? thanks!
     
  2. m j

    m j 1/2 ton status

    Joined:
    Dec 28, 2001
    Posts:
    4,606
    Likes Received:
    0
    hydraulic or manual linkage?
     
  3. fortcollinsram

    fortcollinsram 1/2 ton status

    Joined:
    Nov 8, 2001
    Posts:
    2,261
    Likes Received:
    0
    Location:
    Fort Collins, CO
    I am asumming a hydro b/c it's an 87...What does the fluid look like?if it is dirty, yo u may try bleeding/flushing the system and see what new DOT 3 will do...Could also be the pivot ball for the clutch fork..does you bell housing have a grease zerk on it? if so shoot a little grease in there...Because of the problem is intermitent, I would say it is the fluid or a bad MC or SC or both..I would start at the fluis and pivot ball and go from there...
     
  4. m j

    m j 1/2 ton status

    Joined:
    Dec 28, 2001
    Posts:
    4,606
    Likes Received:
    0
    the 'new' part had me unsure.
    I was thinking if it is hydro you should look at the retainer that the throw out bearing rides on.
     

Share This Page