Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

code 30... not found in any diagnostic guide

Discussion in 'The Garage' started by camiswelding, Jul 18, 2005.

  1. camiswelding

    camiswelding 1/2 ton status

    Joined:
    May 25, 2003
    Posts:
    2,545
    Likes Received:
    0
    Location:
    Redding, CA
    Just finished installing a new BB in my crew and got it running...

    check engine light comes on after 10-15 seconds... code reader shows its throwing a code 30.... 3 quick flashes followed by a pause,,

    timing is out 4 degrees... Im pulling the distributor tonight...its off one tooth

    I cant find code 30 referrenced anywhere...


    Anyone?

    thanks
    cam
     
  2. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,975
    Likes Received:
    189
    Location:
    Roy WA
    It's been so long since I've actually pulled codes...

    Do you get a code 12? IIRC, code cycle starts with 12, then next code, etc., then repeats 12 and starts over. 3 repetitions per each code.

    Aren't the quick pulses the second half of the code? IE, one long flash, then 3 short is code 13.

    Have you tried pulling codes with a paperclip? Wonder if the code reader is somehow messed up.

    I checked the f-body manual, no code 30 referenced.

    All the ones with "3" in them are:

    13, O2 sensor circuit open.
    23, MAT sensor low temp (not applicable to trucks)
    32, EGR failure, (also not applicable to trucks apparently)
    33, MAP low vacuum
    34, MAP high vacuum
    43, ESC
    53, VATS (not trucks)
     
  3. puckhead

    puckhead 1/2 ton status

    Joined:
    Jun 17, 2005
    Posts:
    112
    Likes Received:
    0
    Location:
    colorado
    what year?
     
  4. camiswelding

    camiswelding 1/2 ton status

    Joined:
    May 25, 2003
    Posts:
    2,545
    Likes Received:
    0
    Location:
    Redding, CA
    the truck is an 89


    Im using a gm a/b code reader....
    yes Im getting the correct 12 code showing the system diagnostics are working... three times... then it gives the following

    3 short flashes followed by a longer pause... and repeats...

    in the gm manual with the code reader they actually talk about the above being a code 30...as an example...

    but nowhere is code 30 referrenced in any followup manuals... chiltons...haynes... etc... or the gm code reader instuction book which also has all the codes...

    Im stumped...
    Im going to get the timing right and dump the codes and reset the system....maybe its a code for out of timing?


    cam
     
  5. Thunder

    Thunder 3/4 ton status

    Joined:
    Jul 20, 2000
    Posts:
    8,946
    Likes Received:
    1
    Location:
    Northeast Nevada
    There is no code 30. TBI doesn't use any code number with a 0 in it because 0 would be a pause. So you couldn't tell the diference between a 0 and the next code.. If you are getting 3 flashes over and over it is a 33.
    You are prolly getting a code 33. Which is a map sensor code

    When you pull codes it should flash the code 12 three times.
    Then it pausees and will show any trouble codes stored.

    The trouble codes codes will also display 3 times starting with the lowest numeric first. Each code will flash 3 times. Then It will show a 12 one time showing all the trouble codes stored have been read.

    If you are getting 3 flashes ... pause ... three flashes. That repeats 3 times that is a 33.
     
  6. camiswelding

    camiswelding 1/2 ton status

    Joined:
    May 25, 2003
    Posts:
    2,545
    Likes Received:
    0
    Location:
    Redding, CA
    thanks thunder... Ill check that sensor

    cam
     

Share This Page