Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Computer Questions

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Rooster53, Feb 13, 2002.

  1. Rooster53

    Rooster53 Registered Member Premium Member

    May 8, 2000
    Likes Received:
    Hey Everyone,
    In November I got a GM factory rebuilt 350 put in my 1988 K5. The place that did it is called NECO's. Since the new engine has been installed my oil pressure is constantly at 60 and the check engine lights goes on and off frequently. Also the K5 has shut off on me at least 10 times. I took the K5 back to NECO's and they said the coumputer has no codes in it, and they don't deal with computers. What can I do about this problem? Is there more than just replacing the computer I have to worry about?
    Thanks for all your help,

    Insomnia is your friend!
  2. dyeager535

    dyeager535 1 ton status Premium Member

    Dec 13, 2000
    Likes Received:
    Roy WA
    The computers rarely fail..like the proportioning valve, not understood, so replaced.

    That said, sounds to me like you are dealing with a loose wire, or a chafed wire that is grounding out. I'd think about going through the wiring while the truck is running, and wiggling all the wires you can see/reach.

    My tech/links page: <a target="_blank" href=http://www.dorianyeager.com/index2.html>www.dorianyeager.com/index2.html</a>
    Why insist on counting when the ring gear has the tooth counts stamped in?

Share This Page