Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Cooling issues

Discussion in 'The Garage' started by rusty79beast, Aug 16, 2005.

  1. rusty79beast

    rusty79beast Registered Member

    Joined:
    Sep 30, 2002
    Posts:
    64
    Likes Received:
    0
    Location:
    Houghton, MI
    I have an intermittent cooling problem. It overheats only with the A/C on and running 75mph+. If going just 60 or so, it doesn't overheat. What could be the problem?? Clogged radiator, fan not working properly, thermostat, junk coolant???? The coolant was just replaced, and the system pressure tested OK. I've brought it to a few shops, but they can't find the problem! The outside temperature when this happens ranges from 75 on up. Also seems to like to overheat in heavy stop and go traffic. Anyone have any ideas or suggestions to check?? Thanks guys :bow:
     
  2. cbbr

    cbbr 1 ton status GMOTM Winner

    Joined:
    Jul 17, 2004
    Posts:
    14,681
    Likes Received:
    0
    Location:
    High velocity, Low altitude
    On the stop and go, I would tell you to check the fan clutch. Mine went bad and caused that to hapen. As far as overheating at 75 mph I would guess radiator is cloged, but have no idea really.
     
  3. Roz

    Roz 1/2 ton status

    Joined:
    Mar 27, 2005
    Posts:
    900
    Likes Received:
    0
    Location:
    San Diego
    is it on ure blazer? is the inside of the rad look ok? no gunk u can see? i know its dumb but check front of rad to see if u picked up anything (plasic bag, rag, ect..)

    had girl come to me cause her car was overheating. her boyfriend put cardboard in front of rad to make it warmer for the winter. didnt take it out for summer :haha:

    pump? or possibly cap? it overheating on highway is strange. might be therstat not working properly.

    also tranny could do it if it isnt working right. my car is like that. same symptoms but i know its from towing to big of a trailer over to many passes.
     
  4. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,979
    Likes Received:
    189
    Location:
    Roy WA
    I have no idea what caused me to look this thread up again, as it's very old, but talk about a super time and money consuming problem that someone diagnosed fairly early in to the thread!

    Everything!

    Yeah, it's long, but re-reading the very first post, I see similarities with this problem. It's worth reading IMO. I'd be pissed if I did all that work only to find something that simple as the cause. (and I did, loose crank pulley noise gave me excuse to pull decent 350 and spend a lot more building another :))

    Besides, it's one of my most favorite threads ever.
     

Share This Page