Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Cruise Control is gone.

Discussion in 'The Garage' started by warcat, Feb 20, 2006.

  1. warcat

    warcat Registered Member

    Joined:
    Apr 3, 2005
    Posts:
    26
    Likes Received:
    0
    Location:
    Corpus Christi, TX
    I've got an '85 GMC Jimmy with a new crate 350. When new, the truck came with cruise control, however it no longer works. I was wondering what it would take to get the cruise control working again. I haven't got the slightest clue on how to go about fixing it. Anyone know what I need to do?
     
  2. K5er4Life

    K5er4Life 1/2 ton status

    Joined:
    Oct 16, 2002
    Posts:
    1,456
    Likes Received:
    0
    Location:
    Bellflower, Ca
    Are the pieces there and intact? Vaccum lines hooked up and routed correctly to the diaphram? Does your speedo work? Give us some background info as to whats going on, when I got my crew cab the cruise did not work but I figured it was because the speedo wasnt working. Once I replaced the cable sure enough the cruise worked no prob. So it really could be a number of things, it just needs to be narrowed down a little bit. They are pretty simple systems and dont have alot to them. Make sure the linkage going to the carb is hooked up and properly adjusted, look at that black diaphram behind the carb for hose routing. And after that check electrical connctions.
     
  3. 1985_K5_Silverado

    1985_K5_Silverado 1/2 ton status

    Joined:
    Dec 21, 2005
    Posts:
    984
    Likes Received:
    0
    Location:
    Corn Country
    Carbureted? If it's an Edelbrock carb, they have a mighty inexpensive kit to make the CC work with their carbs (if the CC system is otherwise unmolested). The EB part # is 1484, and it's about 17 bucks at Summit.
     
  4. warcat

    warcat Registered Member

    Joined:
    Apr 3, 2005
    Posts:
    26
    Likes Received:
    0
    Location:
    Corpus Christi, TX
    It is an Edelbrock Carb. But I guess I shouldve known a little more about my problem before I asked for help. I'm pretty vehicle illiterate. I'll try to find out some more about why my particular cruise control isn't working before I repost. Thanks for the replies, though.
     
  5. sled_dog

    sled_dog 1 ton status

    Joined:
    Sep 3, 2002
    Posts:
    16,870
    Likes Received:
    0
    Location:
    Austin, TX
    was it working and stopped or has it not worked since you got it?
     

Share This Page