Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Cruise Control

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by lew, Apr 15, 2000.

  1. lew

    lew Registered Member

    Joined:
    Mar 12, 2000
    Posts:
    39
    Likes Received:
    0
    Location:
    reno,nv
    Hello again,
    Here is the problem. It does not work. Truck is a 86 K5. I checked the obvious one the fuse. looks good. Have any of you had the same prob and been able to get it running again.
    Just wondering if this may be something someone else has run into.
    The local elect shop wants $150 just to look at it and kill me from there. I figured I could get that audiovox VSS cruise for $100 before paying those crooks first.

    Thanks for the help.
     
  2. 8_YOUR_H2

    8_YOUR_H2 1/2 ton status

    Joined:
    Feb 20, 2000
    Posts:
    2,663
    Likes Received:
    0
    Location:
    Iowa
    You should replace the cruise control unit. Mine went bad, I have not replaced it yet but it is prob the cruise unit. Go to a local auto parts store It should be common item. It could be a vacuum problem too check the vacuum line first that would be an easy fix. If the Blazer came with cruise you dont need to install a new cruise, check wrench head or autoparts.com and see if they have it and how much it is..it should be cheap..hey let me know what you find out!!
     
  3. Eagle86K5

    Eagle86K5 1/2 ton status

    Joined:
    Mar 5, 2000
    Posts:
    974
    Likes Received:
    0
    Location:
    Whitehouse, Ohio
    Your problem is in the turn signal lever. There is a black colored wire, in it are four wires, red, yellow, blue and black. These wires run to the control unit. Through constant use the wire breaks right where it goes into the middle of the lever. The black wire goes into the middle of the column to a connector under the dash. Always being one to disassemble things I tried to fix mine, the first time I was able to resolder and heatshrink the wires back, but they soon broke again. So I tore into the lever. It is crazy glued together so most times you get it apart, it is ruined. So your best bet is to go to the junk yard and get another one off almost any GM product. Just make sure it has the cruise botton in the end, gently twist the lever and pull out, then gently try to pull the wire out of the colummn. The ones I have gotten came out easily. Instead of running the wire back through the column I used a few tyraps and left it outside. Now my replacement cost $5.00, the one in J.C.Whitney cost $116.00. Good luck! Any questions just ask...[​IMG]
     
  4. coopertwpk

    coopertwpk 1/2 ton status

    Joined:
    Mar 18, 2000
    Posts:
    478
    Likes Received:
    0
    Location:
    Spring Valley Lake Ca.
    napa has 6 different switches on a spin rack for 20$ apiece check them out.
     
  5. Corey-88K5

    Corey-88K5 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    720
    Likes Received:
    0
    Location:
    Home: Michigan, Stationed: Hill AFB (Home of Moab.
    You think YOU have a problem. Well my cruz works, but when you set it, sometimes it jumps up about 20-40mph and then settles. But more common than not, it "pulses". It acts like somebody is hitting the gas for 1 sec. than stops for a sec, gas, stop, gas, stop, gas, stop. It does this until I hold my foot on the pedal for about 20 miles. I don't have to do much, just keep tension on it. Its annoying as all hell. The only thing I can think of is the vac. canister on the fire wall DS has a broken inlet. I plugged the line, but there is still a hole in the canister.

    Corey
    88K5

    [​IMG]<font color=red>Girls Like Guys In Bow Ties
    http://www.geocities.com/corey_perez
     
  6. Eagle86K5

    Eagle86K5 1/2 ton status

    Joined:
    Mar 5, 2000
    Posts:
    974
    Likes Received:
    0
    Location:
    Whitehouse, Ohio
    Well Corey my friend, if you were closer I would fix it for you, but you would almost have to think of an intermittent connection somewhere then a vac problem. The cannister you speak of supplies vac assist to the heating and A/C
    controls, which you can test easily, set the controls to say vent or heat, then unplug the vac hose to the cannister ball and you will find that the controls no longer work.
    90% of the time folks come to me with electrical problems and cruise problems I have found it to be the wires in the lever. I replace the wires inside with a larger AWG copper strand along with teflon coating versus the plastic. The teflon seems to last longer.
     
  7. Corey-88K5

    Corey-88K5 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    720
    Likes Received:
    0
    Location:
    Home: Michigan, Stationed: Hill AFB (Home of Moab.
    Well I sure wouldn't mind figuring out this stupid problem on my cruise control. Its pretty annoying to drive to the beach and by the time you get there, everybody has whiplash because of the constant stop, go, stop, go, stop, go... And as far as that canister, Hmmmm I guess thats why the Defrost doesn't work. Everything is vent! I was wondering what wires and lever you are talking about. I may look into it.

    Thanks Eagle.

    Corey
    88K5

    [​IMG]<font color=red>Girls Like Guys In Bow Ties
    http://www.geocities.com/corey_perez
     
  8. Zack

    Zack 1/2 ton status

    Joined:
    Feb 18, 2000
    Posts:
    329
    Likes Received:
    0
    Location:
    IL, USA
    Here's an idea.. Drive your truck and not let it drive you! Lol no I like cruise and all just jealous none of my trucks have it. My old car had it but sometimes in traffic when I was coming up to a light the accelerator would just punch all the way to the floor.. I almost rear ended someone more then once.. That was when I decided to take the fuse out. Prob solved!

    <font color=red>Zack Carlson</font color=red>
    <font color=yellow>Carlson@thestix.net</font color=yellow>
     
  9. Eagle86K5

    Eagle86K5 1/2 ton status

    Joined:
    Mar 5, 2000
    Posts:
    974
    Likes Received:
    0
    Location:
    Whitehouse, Ohio
    The lever I was talking about is the turn signal lever....
     

Share This Page