Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Cruise control

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by jville91ck5, Aug 22, 2005.

  1. jville91ck5

    jville91ck5 Registered Member

    Joined:
    May 24, 2005
    Posts:
    19
    Likes Received:
    0
    Location:
    Jacksonville, Florida
    1991 K5 Blazer Silverado 5.7L Cruise does not respond at all. Is there a fuse I can check. I have looked at the fuse box as well as I can.
    Need answers. Thanks
     
  2. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,978
    Likes Received:
    189
    Location:
    Roy WA
    Any chance the owners manual is still in the glove box? That should tell you which fuse is for cruise if so.

    Sorry I don't have more specifics on the fuse stuff, but if you have the manual, hopefully this will save you some time.
     
  3. caleb22

    caleb22 1/2 ton status

    Joined:
    Apr 15, 2005
    Posts:
    193
    Likes Received:
    0
    Location:
    SC
    I have a Chiltons book at home I can look at for you later this evening to see if it helps at all unless someone posts an answer beforehand. I have a 89 K5 but no owners manual.
     
  4. tx_sub

    tx_sub 1/2 ton status

    Joined:
    Mar 5, 2004
    Posts:
    548
    Likes Received:
    0
    Location:
    Denton, TEXAS
    i lost cruise completely a couple years ago on my 91 sub. as part of some maintenance, i replaced a bunch of vac lines. after that, the cruise worked a little: it would work for a while, then loose hold and slow down, or just start slowing down once engaged.
    this is a pic of the cruise module (not that the pic will help anyone, but i'm a pic whore for now)

    maybe the attachment will work...

    cruise control module.jpg
     
  5. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,978
    Likes Received:
    189
    Location:
    Roy WA
    Wow, big change from previous cruise modules!

    Is that one large multi wire plug on it? What/where did that plug in to the vehicle? Where was it mounted? Engine bay?
     
  6. tx_sub

    tx_sub 1/2 ton status

    Joined:
    Mar 5, 2004
    Posts:
    548
    Likes Received:
    0
    Location:
    Denton, TEXAS
    to tell you the truth, i grabbed this pic off ck5 some time ago and don't know the exact application. i just went outside to look at my 91 sub and it looks like there is a similar box mounted to a bracket on the pass head partially covered by the air cleaner assembly. it was too hot to start poking around under the hood (100+degrees here).

    i just tried a search online for the part and no luck....??
     
  7. basketcase

    basketcase Registered Member

    Joined:
    Apr 30, 2005
    Posts:
    52
    Likes Received:
    0
    Location:
    buffalo,ny
    how many miles on the truck? my 90 has 165 on it and the switch on the signal stick is worn out. It used to work, but would go out if you turned the wipers on, now it rarely will set at all, napa sells the stick with the switches for 80 bucks, but it looks like a pain to change because of the wire routing.
     

Share This Page