Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Damn lifters Again....suggestions please

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by twenty_below0, Mar 31, 2002.

  1. twenty_below0

    twenty_below0 1/2 ton status

    Joined:
    May 16, 2001
    Posts:
    436
    Likes Received:
    0
    Location:
    Haines, Alaska ...u.s.
    OK, I had a Comp cam go down in my motor about 3 months ago, several lobes were flat and only after 10,000 miles!! So I bought another and put it in and ever since the lifters wont quit rattleing....and yes they're adjusted right, they dont rattle over 1,800 mostly at an idle, I have checked them more than once, when I removed the cam the lifters were sunk in on the bottoms from the lobes and i had to twist them out of the top of the bores with channel locks, they would come up so far then get stuck, could this have damaged it to make them do this? Also sometimes they are silent then you drive a ways get out again and you can here them again.....not consistent....any help would be great!!!!
     
  2. POWERMAD

    POWERMAD 1/2 ton status

    Joined:
    Mar 4, 2001
    Posts:
    3,466
    Likes Received:
    0
    Location:
    Oregon
    Didyou replace the lifters with the cam?
     
  3. 84_Chevy_K10

    84_Chevy_K10 Banned

    Joined:
    May 30, 2001
    Posts:
    17,669
    Likes Received:
    0
    Location:
    IL, USA
    Comp would have given you a new cam for free if you would have sent it back.
     
  4. rx7xj

    rx7xj Registered Member

    Joined:
    Mar 17, 2002
    Posts:
    36
    Likes Received:
    0
    Location:
    East TN
    How fresh is your motor? A cam can go bad pretty quick if your oil pressure is down due to worn bearings
     

Share This Page