Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

DANA 60 HUB STUD HOLE REPAIR

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by JDELBLAZ, Jun 16, 2003.

  1. JDELBLAZ

    JDELBLAZ 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    140
    Likes Received:
    0
    Location:
    STAMFORD C.T
    i have 2 stud holes in my dana 60 hubs that are worn and the studs are loose in them is there any way to fix this because i dont want to buy new hubs
     
  2. monte0172

    monte0172 1/2 ton status

    Joined:
    Sep 16, 2002
    Posts:
    182
    Likes Received:
    0
    Location:
    Memphis, TN
    Mig welder!!!
     
  3. 87sm465np208

    87sm465np208 1/2 ton status

    Joined:
    Aug 28, 2002
    Posts:
    1,114
    Likes Received:
    0
    Location:
    illinois
    bigger stud? as far as the part that presses in that is. /forums/images/graemlins/thumb.gif

    /forums/images/graemlins/usaflag.gif /forums/images/graemlins/truck.gif
     
  4. Seventy4Blazer

    Seventy4Blazer 3/4 ton status

    Joined:
    Apr 21, 2001
    Posts:
    5,634
    Likes Received:
    0
    Location:
    Escondido, CA
    well my 97 geo metro had the same problem, but it was 3 of the 4 studs that did it. i bought factory replacements, pressed them in the little they would hold then welded 3 small but deep tack welds on each stud. matter of fact i did all 4 of them. no problmes after that.

    now, if it was on a 14 bolt FF i would say find larger ones. napa has a great book for finding stuff like that.
    Grant
     

Share This Page